roundcube username_domain @localhost

Hi

My Debian Postfix Dovecot mail server is nearly ready for delivery (installed with the latest versions and updates)

Rather than create virtual users (max 30 users), I opted for PAM authentication using system accounts because this allowed domain-less logins, and Usermin password management.

The snag is that Roundcube doesn't allow me to 'add' the @domain extension to the account name.

The result is that emails are then sent from name@localhost and upon arrival they seem to have swapped the @localhost part with the recipient's ISP own @domain

Thus you can't respond to the email, without retyping the correct domain name

I have tried using the following parameters in db.inc.php :

//$rcmail_config['username_domain'] = 'holinice.com';
//$rcmail_config['default_host'] = 'holinice.com';

...but then the user can't log in anymore because the login is seen as name@domain

I even tried to update the email address that is stored in the 'identities' table of the Roundcube database, but again, authentication fails

Any ideas ?

thanks

yann
Yann ShukorOwnerAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Yann ShukorConnect With a Mentor OwnerAuthor Commented:
After receiving a response from the trac.roundcube.net we made a new attempt at modifying the user's email address in the Identities table present in the Roundcube mysql database.

This time it worked. it isn't an ideal solution but it works.
0
 
Yann ShukorOwnerAuthor Commented:
We were wrong to indicate that manually modifying the the user's email address in the Identities table present in the Roundcube mysql database wasn't a viable option since our last attempt was successful
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.