• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 257
  • Last Modified:

VPN and Application

Dear EE,

My application hangs when i connect to the VPN (cisco VPN Client 5.0) from my Laptop.

Please help .

Thanks
0
Netsol-NOS
Asked:
Netsol-NOS
  • 5
  • 3
  • 2
1 Solution
 
asavenerCommented:
When you say it hangs, do you mean that it hangs when you launch the application, or do you mean that it works for a time and then hangs?
0
 
Wayne MichaelSenior Software DeveloperCommented:
If you app is connected to local resources and your VPN removes your ability to talk to those local resources then that is the issue.

I would contact your VPN support folks to make sure your VPN is setup property for your app.

Please provide more information about your application and how it communicates on the network.
0
 
Netsol-NOSAuthor Commented:
Dear Asavener,

It totally hangs. Secondly todays i monitor that my application port which is 2000 telnet successfully but DB port 1433 do not telnet.
But when i DISCONNECT the VPN my application connect sccessfully with out any error or problem.

Thanks
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Netsol-NOSAuthor Commented:
Dear wrmichael,

You are right, But can you elaborate please what will be the issue.

Thanks
0
 
Netsol-NOSAuthor Commented:
We are using Powerbuilder 12.5 and EAServer 6.3.1 moreover in database we are using  SQL 2008R2
0
 
Wayne MichaelSenior Software DeveloperCommented:
my guess is your VPN connection changes your DNS settings and the DB server is unreachable.

try to ping your Database server before and after you make the connection.

see if your DNS servers change from before to after the VPN connection.
0
 
asavenerCommented:
Open the Cisco VPN client, highlight the connection item, select Modify.  Then go to the Transport tab and make sure "Allow Local LAN Access" is checked.

Policies on the ASA can override this setting, so it is not always effective.
0
 
Netsol-NOSAuthor Commented:
Dear Asavener,

My this option is disable...
0
 
asavenerCommented:
Do you mean it is not checked, or that it is greyed out?

If it's greyed out, then the setting is forced by the VPN administrator, and you can't change it.

If it's just unchecked, then try checking the box and testing.


If the setting is forced by the VPN administrator, then you can't have the VPN and the application active on the same machine at the same time.  If you need access to both at the same time, then you will need a second machine (perhaps a virtual machine on your desktop PC to access the VPN).
0
 
Netsol-NOSAuthor Commented:
The client resolved the issue with change in there VPN configuration.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now