Problem installing Exchange 2013

Hello.
My Exchange installation stops at 97% (Mailbox role: Transport service) with the following message:

Error:
The following error was generated when "$error.Clear();
          $maxWait = New-TimeSpan -Minutes 8
          $timeout = Get-Date;
          $timeout = $timeout.Add($maxWait);
          $currTime = Get-Date;
          $successfullySetConfigDC = $false;

          while($currTime -le $timeout)
          {
            $setSharedCDCErrors = @();
            try
            {
              Set-SharedConfigDC -DomainController $RoleDomainController -ErrorVariable setSharedCDCErrors -ErrorAction SilentlyContinue;
              $successfullySetConfigDC = ($setSharedCDCErrors.Count -eq 0);

              if($successfullySetConfigDC)
              {
                break;
              }
              Write-ExchangeSetupLog -Info ("An error ocurred while setting shared config DC. Error: " + $setSharedCDCErrors[0]);
            }
            catch
            {
              Write-ExchangeSetupLog -Info ("An exception ocurred while setting shared config DC. Exception: " + $_.Exception.Message);
            }

            Write-ExchangeSetupLog -Info ("Waiting 30 seconds before attempting again.");
            Start-Sleep -Seconds 30;
            $currTime = Get-Date;
          }

          if( -not $successfullySetConfigDC)
          {
            Write-ExchangeSetupLog -Error "Unable to set shared config DC.";
          }
        " was run: "Unable to set shared config DC.".



There is some articles in the Internet related to the same message, but the problem always turn out to be related to IPv6 being disabled on the DC.


This is my servers:

server 2008R2 doman controller (AD 2008R2 level, two sites but all servers are in site 1)
server 2008R2 exchange 2010 with all updates and SP3 (CAS and MBX role)
server 2012 on witch i try to install exchange 2013 (CAS and MBX roles)

-  All servers has the AD and link layer topology service running
-  All servers are updates
-  All servers are able to ping each other on private IPv6 adresses (manual, no gateway on ipv6)


The event log on the exch2013  server gives these two interesting messages:

Message 1:

Microsoft.Exchange.Directory.TopologyService.exe
   5188
   bjarnessen.local
   No Suitable Directory Servers Found in Forest bjarnessen.local Site Hjellestadvegen234C.


MESSAGE 2:


MSExchangeHMWorker.exe (ExHMWorker)
   2428
   Get Servers for bjarnessen.local
   TopologyClientTcpEndpoint (localhost)
   3
   An error occurred during forest discovery (bjarnessen.local). ----> No Suitable Directory Servers Found in Forest bjarnessen.local Site Hjellestadvegen234C. at Microsoft.Exchange.Directory.TopologyService.ADTopologyDiscovery.Discover() at Microsoft.Exchange.Directory.TopologyService.ADTopologyDiscovery.DoWork(CancellationToken cancellationToken) at Microsoft.Exchange.Directory.TopologyService.Common.WorkItem`1.Execute(CancellationToken joinedToken) at Microsoft.Exchange.Directory.TopologyService.Common.WorkItem`1.<>c__DisplayClass6.<StartExecuting>b__4() at System.Threading.Tasks.Task.Execute() ----------- at Microsoft.Exchange.Directory.TopologyService.Common.Extensions.WrapAndRethrowException(Exception exception, LocalizedString errorMessage) at Microsoft.Exchange.Directory.TopologyService.TopologyDiscoveryManager.EndGetTopology(IAsyncResult ar) at Microsoft.Exchange.Directory.TopologyService.TopologyService.InternalEndGetServersForRole(IAsyncResult result) at Microsoft.Exchange.Directory.TopologyService.TopologyService.<>c__DisplayClassa.<EndGetServersForRole>b__9() at Microsoft.Exchange.Directory.TopologyService.TopologyService.ExecuteServiceCall(Action action)




I believe that the event log messages is related to the problem here, but i have no clue where to go from here.

I appreciate all help here.
Thanks!
Exchange-install-2013-stops.png
LVL 1
Thomas-NorwayAsked:
Who is Participating?
 
Thomas-NorwayConnect With a Mentor Author Commented:
Hello.  The issue was related to DNS and AD problems.

I deleted an unused ad site and found tracs from an ad controller that was removed in 2008 :)

Removing all tracs of old/dead ad controllers, and removing the unuses ad site, solved the case.

Now I have a new problem :)  I will create a new question for this, since it is not related to the original problem.

I hope you guys can help me solve that one too.   Thanks!
0
 
Haresh NikumbhConnect With a Mentor Sr. Tech leadCommented:
so have you turn off IPv6 ?

I have faced same issue, after lot of research i used FIXIT which turn off IPV6 from registry .. rebooted server and then start installation which worked for me.
0
 
Thomas-NorwayConnect With a Mentor Author Commented:
All other articles i have seen on google and microsoft says that the problem occurs when IPv6 is disabled.  Many people solved it by enabeling IPv6, so I made sure IPv6 was enabled :)

Did you disable IPv6 on all domain and exchange servers, or just the server on which you tried to install exchange 2013?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Haresh NikumbhConnect With a Mentor Sr. Tech leadCommented:
Many people solved it by enabeling IPv6, so I made sure IPv6 was enabled :)  thts true

infact i have read somewhere . only disabling from network property will not worked. they have to disabled from registry too
 

it was test lab server, where AD and Exchange is installed.
i know MS does not recommend both on the same server but as its test lab so i just tried disbaling IPV6
0
 
Thomas-NorwayConnect With a Mentor Author Commented:
ok.  I will try to disable IPv6 on both exch2013 server and the DC server.

It does not seems like FIXIT is supported for server 2012
0
 
Thomas-NorwayConnect With a Mentor Author Commented:
I disabled IPv6 on the 2012 server i tried to install exchange 2013.  IN registry and local ethernet properties.

The same happend.  

Could it be something wrong with the AD topology service?
0
 
Thomas-NorwayConnect With a Mentor Author Commented:
I also tried to disable IPv6 in the DC, with the same result.
In registry and in properties of local network adapter

Since it did not work, I enabled full IPv6 support again on all servers.
0
 
Vasil Michev (MVP)Connect With a Mentor Commented:
Do not disable IPV6, do not even uncheck the tick in network settings. I've had the same issue when trying to install E2013 on the DC, imagine how mad I was when it complained that it cannot find the DC :)

In your case you probably need to enable it on rest of the servers as well. Or better yet, start clean on a new VM.
0
 
Thomas-NorwayAuthor Commented:
0
 
Thomas-NorwayAuthor Commented:
I found the problem myself
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.