Solved

Exchange 2010 Proxy not working properly for OWA

Posted on 2013-05-28
15
3,272 Views
Last Modified: 2013-05-28
We have an Exchange 2010/2007 environment. Out internet facing site has the 2010 CAS/HUB server which answers to https://owa.domain.com/owa and a 2010 CAS/HUB/Mailbox server as well as a legacy 2007 CAS/HUB and CAS/HUB/Mailbox server in it. It works fine for all exchange servers (2010 and 2007) in that site.

Our other site (we'll call it site2) consists of a 2010 CAS/HUB/Mailbox server and a legacy 2007 CAS/HUB/Mailbox server. Basically, when an internal 2010 user tries to connect to the https://owa.domain.com/owa, it proxies to the server (site2-2010-exchange.domain.com/owa) but it appends /ping.owa to the end of the url. So instead of HTTPS://site2-2010-exchange.domain.com/owa, it returns https://site2-2010-exchange.domain.com/owa/ping.owa which gives a 404 error.

If I manually remove the ping.owa, it works fine. That is not a solution for us though. I need to know why it is doing this and correct it so when we move the rest of users to 2010, they won't have this issue. The current users on 2007 do not have this issue. It redirects to the https://site2-2007-server.domain.com/owa with no issue.

Anyone seen this before. Having trouble finding relevant articles regarding this online.
0
Comment
Question by:stmadmin
  • 8
  • 7
15 Comments
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202708
Make sure the auth method on teh OWA virtual directory in Site1 is Windows-integrated
Set the ExternalURL to $Null on site2
Make sure InternalURL is teh FQDN of site2's exchange server.
0
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202716
Also post your results to: get-owavirtualdirectory <servername>\owa* | FL Identity,*auth*
0
 

Author Comment

by:stmadmin
ID: 39202730
get-owavirtualdirectory stm0exmb01\owa* | FL Identity,*auth*

Identity                      : Site2-2010-exchange\owa (Default Web Site)
ClientAuthCleanupLevel        : High
InternalAuthenticationMethods : {Basic, Fba, Ntlm, WindowsIntegrated}
BasicAuthentication           : True
WindowsAuthentication         : True
DigestAuthentication          : False
FormsAuthentication           : True
LiveIdAuthentication          : False
ExternalAuthenticationMethods : {Fba}
0
 

Author Comment

by:stmadmin
ID: 39202732
Identity                      : Site1-2010-exchange\owa (Default Web Site)
ClientAuthCleanupLevel        : High
InternalAuthenticationMethods : {Basic, Fba, Ntlm, WindowsIntegrated}
BasicAuthentication           : True
WindowsAuthentication         : True
DigestAuthentication          : False
FormsAuthentication           : True
LiveIdAuthentication          : False
ExternalAuthenticationMethods : {Fba}
0
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202736
So WindowsIntegrated was already enabled yes?
0
 

Author Comment

by:stmadmin
ID: 39202744
Yes, I haven't changed anything yet.
0
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202752
So what what about the External and Internal URL variables?
0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 

Author Comment

by:stmadmin
ID: 39202754
Also, ExternalURL is already $null and internal url is correct as well.
(https://site2-2010-server.domain.com/owa)
0
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202756
Also did you do any configuration changes to any of the virtual directories using IIS or via ESM?
0
 
LVL 14

Accepted Solution

by:
Ben Hart earned 500 total points
ID: 39202761
try removing Form-based Auth via EMC-Server Config-Client Access-Site2 server-Outlook Web App, Authentication tab.  then restart IIS

Also make sure your IP's in both v4 and v6, are bound to the default website
0
 

Author Comment

by:stmadmin
ID: 39202791
Oddly enough, the https bindings were blank. I forced it to use all available addresses. I have a guy out there at that site checking it now. If it still fails, then I will remove FBA and make it integrated and basic only.
0
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202804
You can also try recreating your Virtual Directories.. easy enough from the Console.
0
 

Author Comment

by:stmadmin
ID: 39202812
Removing FBA did it. Thanks a lot man. ubadmin = ubdaman

Appreciate it.
0
 

Author Closing Comment

by:stmadmin
ID: 39202816
Excellent, fast, concise and on the money. Awesome EE member.
0
 
LVL 14

Expert Comment

by:Ben Hart
ID: 39202818
Much obliged! Glad your working now.
0

Featured Post

Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now