Solved

Virtual SMTP Server - IIS 7.0 - Can't send to internal Exch 2007 server

Posted on 2013-05-28
4
363 Views
Last Modified: 2013-06-04
Hi experts,

I have a problem with sending email from internal IIS smtp server to internal users though exchange server.

We have a domain with Exchange 2007/windows2008, DC/Windows2008 and IIS/Windows2008 servers and around 15 PCs.

The IIS/Windows2008 has a custom app which creates an application form  and will send to exchange and users will receive. this is all happening internally.

The problem is the IIS can send email to external address (e.g gmail, yahoo) but can't send to internal address and just sits in qurere folder.so as workaround we are sending email to external address and it autoforwards to our email address but I want to avoid to do this.


It looked very similar to link below and I enabled smart host and added mx record on DNS but sill no luck.  I can confirm that port 25 is opened from IIS to exchange.

http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_24293242.html
(Virtual SMTP Server - IIS 5.0 - Can't send to internal domain through local Exch 2003 server)

Any thoughts?

Yasu
0
Comment
Question by:YasuYasu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 4

Expert Comment

by:rlog
ID: 39203709
What account do you use to connect to Exchange? Does this account get "login failed" or similar?
0
 

Author Comment

by:YasuYasu
ID: 39206214
rlog

Only Anonymous access is ticked on access tab on IIS. Connection control and Relay are both "All except the list below" is selected.  

the error occurring is below and it has never been sent.

"Reporting-MTA: dns;name of our IIS server
Received-From-MTA: dns;name of our IIS server
Arrival-Date: Tue, 28 May 2013 15:07:06 +1200

Final-Recipient: rfc822;recipent address@xxx.org.nz
Action: delayed
Status: 4.4.7
Will-Retry-Until: Thu, 30 May 2013 15:08:14 +1200"

JFY, the IIS is trying to send email with PDF attachment which the size is about 100kb.

Thanks.
0
 

Accepted Solution

by:
YasuYasu earned 0 total points
ID: 39209908
rlog,

i solve this myself. Sounds silly but I didn't restart IIS when I made any changes. After MX record is added, restarting IIS solve the problem.

Thanks for your help.

Yasu
0
 

Author Closing Comment

by:YasuYasu
ID: 39218430
I have solved the problem myself.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A safe way to clean winsxs folder from your windows server 2008 R2 editions
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question