• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1159
  • Last Modified:

Cannot connect to Exchange 2010 with Outlook

Hello,

Here is something odd. I haven't seen this issue before, but it has now happed twice to me and I am not sure what is going on. I have a test domain on VMWARE, and I installed Exchange 2010. I have been able to connect to my test accounts using Outlook 2010 (32bit) using MAPI, but now I am unable to do that. I can connect to my test accounts with OWA, but MAPI complains.

Here is a quick breakdown of my environment:

Active Directory is installed on Windows Server 2008 R2 with all the latest and greatest service packs and updates.

Microsoft Exchange 2010 is installed on another Windows Server 2008 R2 system. It is a member server.

My third computer is a Windows 7 (x64) operating system with Office 2010 (x86) installed. It is a domain member.

DNS is on the DC and each system uses the DC as the primary DNS server.

At first, when I setup my workstation and after installing Outlook 2010, I could connect to my test accounts just fine. I could connect to any account (my admin user also has full access control on each test user account) without error. I created multiple Outlook profiles just by typing in the server name or IP address, and then the user name. I prompt for profiles. This has worked fine for a couple of days.

Today, I get errors when I try to connect to Exchange 2010 with my Outlook client and even using the same profiles. When I let autofind find my account or if I do it manually, the server name resolves and the user name resolves to something odd. It changes my test user from Brian Wall to =SMTP:brian.wall@testdomain.local. When I check the name or try to connect I get the following error message:

"The name cannot be resolved. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."

My firewalls are turned off.

What could be causing this? I am not using RPC over HTTP; however, it is possible that a Windows Update might have installed SP3 (I haven't checked yet). If Windows Update did patch me to SP3 then how would I turn off RPC over HTTP on my Exchange 2010 server?

I don't want to install this test domain again if I don't have to. Please let me know if you have an idea why this problem would start happening and how to go back to a normal MAPI connection again.

Thank you,
John

PS: I just tried OWA. I guess I cannot get into OWA either. I get a warning that says:

"The security certificate presented by this website was issued for a different website's address. this problem might indicate an attempt to fool you or intercept any data you send to the server." So, OWA isn't even allowing me in.
0
jhieb
Asked:
jhieb
  • 2
  • 2
1 Solution
 
Stelian StanCommented:
0
 
jhiebAuthor Commented:
I was able to create an Outlook profile and log in as my user by issuing the following command from your second tech note.

Set-RpcClientAccess –Server <Exchange_server_name> –EncryptionRequired $False

Thank you.
0
 
Stelian StanCommented:
Glad I could help you.
0
 
jhiebAuthor Commented:
This problem is happening again. All I did was reboot my Exchange Server. I entered the same command as before; however, it had no effect because it was already set. Do you know why it worked once but not it will not work? What else do I need to look at?
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now