• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 725
  • Last Modified:

MySql will not update via phpmyadmin

Hello,
I have a MySql database on a 1and1 server.

I wish to update a field tinyint(1) which defaults to NULL.

I use phpmyadmin
From Browse I go into the edit form and update the field with a tick box.

When I look at the record  via Browse the field is still at NULL.

If I go back into Edit Mode the tick box is still ticked.

Has anyone any idea how this can be rectified please?
Many thanks

John
0
johnhardy
Asked:
johnhardy
  • 2
  • 2
2 Solutions
 
TvMptCommented:
Hi.

I guess when you change the table structure and the field still accepts null you must update all records with a number from [0..9] (tinyint(1))

Could you show a screenshot of the tick box you are talking?
0
 
johnhardyAuthor Commented:
I am not sure if the edit form is a normal part of phpmyadmin I expect it is.

I am attaching a shot of the edit / update form
Edit-Form.jpg
0
 
Ahmed HusseinCommented:
Uncheck that box if it's the NULL checkbox, it sets the default for the filed to null.
0
 
TvMptCommented:
If you want to disable null values for that records you have to untick the box and write default values in the record or make a massive update to 1 or something in all rows for that 2 columns (frontpageshow / imageshow )
0
 
johnhardyAuthor Commented:
Many thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now