Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 416
  • Last Modified:

Provide valid name instead of localhost in apache 2.2

Hi,

I need to provide a logical name to the site in apache

in the httpd.conf file i have added the virtual host

<VirtualHost *:80>
    DocumentRoot "C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\example1"
    ServerName www.textexample123.com
 
    # Other directives here
</VirtualHost>


and when i try to execute the site with the name " www.textexample123.com" it goes to the internet for searching the url instead it should point to the project i am running.

Is there any other modification i need to make  in the file.
httpd.txt
0
Rocking
Asked:
Rocking
2 Solutions
 
DOSLoverCommented:
As per apache documentation (http://httpd.apache.org/docs/current/vhosts/name-based.html), " ... Of course, you can't just make up names and place them in ServerName or ServerAlias. You must first have your DNS server properly configured to map those names to an IP address associated with your server."

Are you testing this on the local server? Probably using proxy might help what you are trying to.
0
 
Dave BaldwinFixer of ProblemsCommented:
You can also put it in your 'hosts' file (/etc/hosts).
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now