Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 428
  • Last Modified:

Out of Office Exchange 2010

I am no Exchange Expert so any pointers will require specific direction.

Facts:

Our internal Out of Office works.  External does not.

We currently operate 3 Sites with all the Company Mail leaving through 1 main site.  

I ran

Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl

and it returned the 3 sets of details below I am not convinced that these settings are as they should be.

Result1
Identity:         SITE1SRVEXC-01\EWS (Default Web Site)
InternalUrl:    https://site1srvexc-01.domain.co.uk/EWS/Exchange.asmx
ExternalUrl:    https://nowa.domain.co.uk.ews.exchange.asmx

Result2
Identity:         SITE2SRVEXC-01\EWS (Default Web Site)
InternalUrl:    https://site2srvexc-01.domain.co.uk/EWS/Exchange.asmx
ExternalUrl:    blank

Result 3
Identity:         SITE3SRVEXC-01\EWS (Default Web Site)
InternalUrl:    https://site3srvexc-01.domain.co.uk/EWS/Exchange.asmx
ExternalUrl:    blank




With thisResult 1 the problem I have is nowa is a prefic for the Outlook Web Access for a site that name beings with n this is a site identification

1st site is nowa.domain.co.uk/owa
2nd site is bowa.domain.co.uk/owa
3rd site is lowa.domain.co.uk/owa

From what I have read I should remove the n for the external url.  Can anybody confirm that?

The other 2 sites do not have external urls I can only assume this is because all email comes in and out through one site as it has a Barracuda Spam Firewall there.

Any help of fault finding steps would be appreciated.
0
FMabey
Asked:
FMabey
  • 2
1 Solution
 
Vasil Michev (MVP)Commented:
The most common cause in such cases is the actual anti-spam filter. Please make sure that it is allowing the OOF messages and perform a trace to validate if needed.

If this is not the case, check the following options: "Message Format", "Allow automatic replies" and "Allow automatic forward" for the remote domains

Make sure that the users have configured External OOF in Outlook/OWA or make sure that the output of the following command is 'External'

Get-Mailbox user@domain.com | fl ExternalOofOptions



I'm not exactly sure what you mean by the second part of the post, but just in case, make sure that the External URL is actually accessible. If needed, do the test from ExRCA:


https://www.testexchangeconnectivity.com/
0
 
Simon Butler (Sembee)ConsultantCommented:
Can you actually verify what doesn't work here? It isn't clear.
Are you able to SET the OOTO message from outside?
If you can, is that the message doesn't go out?

You do NOT need Allow Automatic Replies and Allow Automatic Forwards enabled for OOTO to work and I would strongly discourage you from setting those options. They allow users to setup rules to send their email off site automatically and it will just be a matter of time before that causes you a problem.

Simon.
0
 
FMabeyAuthor Commented:
Sorry for delay on getting back.  I have now been drafted onto another tasking but plan on resolving this as an ongoing priority.

Internally and between our 3 sites OOO works.

When an external address emails a user with within out company with the  OOO set the sender of the email receives no OOO repoly from the person they emailed.  To my knowledge this has not worked since we migrated from Exch03 to Exch 2010.

We have a barracudda Spam Filter I believe this could be the cause but i want to ensure all configuration on exchanges is complete before i start on the Barracuda box.
0
 
Simon Butler (Sembee)ConsultantCommented:
If Internal to the Exchange org works fine, and you have it set to allow external OOTO in the Exchange configuration, then there is nothing else that you can do Exchange wise.
Use Message Tracking to verify the OOTO message was generated and passed on. If Message Tracking shows it was, then the problem is outside of Exchange.

Simon.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now