Solved

Symantec Ghost - run client task from console

Posted on 2013-05-30
10
184 Views
Last Modified: 2016-11-23
I have been running gss 2.5.1 -  11.5.1.2266 for a while now and I have always been able to run a command from the console that causes an action on the clients. For example, I can run a bat file saved on the client machines by entering c:\file.bat and running the task on the appropriate machines, and it works.
I have had windows 7 machines (dell optiplex 790) for about 3 years now, and this procedure has always worked. This also worked with my windows xp machines.
About 2 weeks ago, though, my clients stopped responding to these tasks. The tasks don't fail, the client just doesn't respond.
To my knowledge my server (windows server 2008 r2 standare x64) has not changed. It is a virtual server with probably several router hops in between it and the lab it controls, but it has worked for over a year now.
I can go to the client and run the bat file manually, and it works as it should. I can enter the command in command prompt (client) to run the bat file and it works as it should.
When I try to execute a task that runs the bat file it says it "finished" and everything executed successfully, but on the client side, nothing happens. I have restarted all client machines, and ghost server, and even the virtual server more than once.

The server is able to push and pull images to/from the server though.

I have over 400 computers that I am constantly needing to run tasks on, and individual interaction is not really acceptble. Any ideas?
0
Comment
Question by:dwils15
  • 5
  • 3
10 Comments
 
LVL 9

Expert Comment

by:BigPapaGotti
ID: 39207845
Has there been any adjustments in the firewall/routers between the ghost server and the clients that would be preventing this type of traffic, or even a recent anti-virus roll out that sees this file as foreign and blocks it from executing properly?
0
 
LVL 1

Author Comment

by:dwils15
ID: 39207894
Not to my knowledge. I am at a large university, and I just spoke with the IT department, and they said they haven't made any kind of changes since february. And even those shouldnt have any effect.

I have my client computers locked down tight with an ACL and I dont even run AV software on them.

Here is an update that I had just discovered:
This morning, about 2 hours ago, I ran a command to kill a program that opens at startup on about 150 clients. Nothing happened. It said it completed but nothing has shown on the clients.
About 40 minutes ago I ran the same command on 6 computers. It says it completed, but nothing had shown, at first. I watched for about 10 minutes and still nothing. After about 30 minutes I had come back and checked the computers, and they had all successfully completed the task, and the program was closed. Its as if it is just taking a long time to take effect, but Im not sure why.
The server shows it compelted successfully when sent to a small number of computers, but it takes a long time for it to happen. When sent to a large number it shows completed successfully, but never appears. If it were a network issue, slowing down the task, why would the server show successful completion, if it is the client side taking long to react, why wouldn't the large number complete?
0
 
LVL 9

Expert Comment

by:BigPapaGotti
ID: 39207984
This is a tricky one with a lot of variables that could be affecting it. A couple of things I would check.

When running this same "close a program" bat file locally does it complete instantly?
Perhaps the server is showing completed because all it is doing is sending the BAT file off to the computer and that process is really fast but the actual execution that is occuring is not being accounted for in the "completed" process.
What if you dumb down the scrip to open a file/program instead, perhaps the application is in use at the time they command is running and can't be closed and it keeps trying until the application is idle?
Is there any sort of logging enabled to show the delay or any errors such as in the BAT file or in event viewer of the computer?
How are updates handled on the computers? perhaps a recent push from a GPO or Windows Update caused the slow down to occur?

I know a lot of these may not apply but just trying to narrow it down for everyone.
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 1

Author Comment

by:dwils15
ID: 39208222
Thanks for the feedback.

1. Yes, running the bat localy is instant.
2. The script is taskkill /IM start_test.exe
3. I dont see anything in the event log files.
4. My access list only allows windows updates when the ACL is turned off. Which was recently turned off, so this could be related.
0
 
LVL 1

Author Comment

by:dwils15
ID: 39241240
I have contacted symantec. They have an open case (for over a week now) and I am still waiting on an answer from them.
0
 
LVL 1

Author Comment

by:dwils15
ID: 39319277
I have been in contact for over a month now. They are addressing this problem and another, which is that for some reason about 15 of my 340 optiple790 machines will not boot into windows after running a configuration task. They are focusing on that one right now.
They have tried several things - updating my GSS with a patch, trying sysprep, which windows 7 will not allow, remoting into my server and client and cannot figure out the problem, and it keeps getting "escalated".
0
 
LVL 9

Expert Comment

by:BigPapaGotti
ID: 39331398
Thank you for keeping us updated. Please continue to do so as it will help us all out in the long run. Hopefully they get this resolved for you soon
0
 
LVL 1

Accepted Solution

by:
dwils15 earned 0 total points
ID: 39540359
I have figured out the reason for the 15 machines not responding or booting properly. There was a firmware updated for the hard drives, that I ran, and has since fixed the problem for those machines.
Also. symantec sent me a patch for the gss 2.5.1 to update my server and clients with. I dont know that this specifically solved the problem, but over the past few months I have been able to push the task of opening bat files and it responds quickly like it used to. I think the patch and the firmware update together helped.
0
 
LVL 34

Expert Comment

by:Seth Simmons
ID: 40845700
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux Desktop suggestion for Dell Inspiron 3043 13 39
Inactive computer in domain 7 64
VMware 6.5:  USB devices 16 58
Install esxi 6 14 33
When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
This guide will walk you through the essential considerations and tech stack for building scalable websites. Know how to grow your business the smart way!
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question