Solved

RDP Not Working on Virtualized 2008 R2 Server Running on Hyper-V R3

Posted on 2013-05-30
9
881 Views
Last Modified: 2016-11-23
Greetings!

We have a virtualized Terminal Server running Windows Server 2008 R2, which has been working perfectly well under VMWare 5.0.  We converted it using the free 9 five V to V utility to run under Hyper-V.  The host we are running the converted VM on is a Dell PowerEdge 2950 with Server 2012 Datacenter installed.

The converted VM is running on the Hyper-V host, and has Internet connectivity and access to shared files on other servers on our domain.  The only thing that isn't working properly is the ability to RDP into the server.  The server is setup to listen for RDP on port 3394, and we verified that setting in the registry.  The firewall is off.  When trying to connect from a Windows 7 RDP Client the connection times out.

The 2950 has two Broadcom Netxtreme II NICs.  NIC teaming is not turned on, and one of the NICs is bound to Hyper-V.

From what we've researched this is probably an issue with the virtual NIC configuration, but we would appreciate guidance on next steps to try.

Thank you in advance for your help!

Doug
0
Comment
Question by:djhunt01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39208319
Are you able to ping VM from Win7 machine?
0
 

Author Comment

by:djhunt01
ID: 39208489
Hi!  Thank you for your response.  Yes, we're able to ping the VM from the Win 7 machine.

Doug
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39208859
The windows firewall will by default create a firewall exception for remote access when enabled, however this will default to port 3389.  3394 will be blocked unless you create the rule manually.  Perhaps try disabling the firewall all together as a test.

I assume this was configured before but the NIC and firewall would have been reconfigured by the hyper-V integration tools when migrated.
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 

Author Comment

by:djhunt01
ID: 39208982
Hi Rob!  Thank you for your input.

The firewall is and has been disabled.  Any other suggestions would be welcome!

Thank you and take care!

Doug
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39209151
My apologies, in re-reading I see you already stated; "The firewall is off."

Have you verified the server is listening as it should on the correct port using
netstat -an |find "3394"
It should return:
TCP    0.0.0.0:3394           0.0.0.0:0              LISTENING

You could also try telneting from another station to verify it is accessible
telnet <IP> 3394
Which should return a flashing cursor and blank window.  An error or timing out would indicate a connection issue if it is listening above.
0
 

Author Comment

by:djhunt01
ID: 39209246
Hi Rob!  Thank you for continuing on this adventure.

Netstat did not show port 3394.  However, I think we're narrowing down the problem.  If I go into the settings for the local area network connection, it shows the static address we set of 192.168.0.26.  However, if we do an IP config it shows an APIPA address as well as 192.168.0.26.  Is there a mapping somewhere involving a virtual NIC that we should be checking?

Also, we can access the machine by installing VNC on it.

Thank you and take care!

Doug
Network-Connection-Details-Scree.jpg
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 500 total points
ID: 39209279
Check under the properties of the network adapter, Internet Protocol Ver 4 (TCP/IPv4) properties, that the static IP is configured under the general tab and not the "alternate configuration tab".

It looks as if DHCP (Obtain an address automatically) is configured under general and static under alternate.  That will not work.
0
 

Author Comment

by:djhunt01
ID: 39209351
Hi Rob!

That was almost it...It was actually the other way around, which is interesting.  I think the conversion process from VMWare provided us some "gifts".

I can't thank you enough for your help with this.

Take care!

Doug
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39209398
Glad to hear you were able to resolve.  It is often recommended to remove NIC's or convert them temporarily to loopback adapters when converting or cloning.  I suspect this is one reason why.

Cheers!
--Rob
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article explains how to install and use the NTBackup utility that comes with Windows Server.
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question