Drupal

I am trying to install some new modules on my development site.

The url to the development site is amcindustries.com.previewdns.com. The reason for this odd url is that the current existing customer web site is live at amcindustries.com; we of course do not want to point that domain to the drupal site until we are ready.

Here is the issue. I try to install new Modules on this site. When I do that, the module install process gets confused & thinks it should install at amcindustries.com, which, of course fails.

I tried is using the IP address. I get a page that says "page OK" in small letters at the top.

Is there a way around this?
Richard KortsAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
nanharbisonConnect With a Mentor Commented:
The default settings file is the one that comes with Drupal and is turned into settings.php. So change the settings.php.
Try setting it to
$base_url = 'http://amcindustries.com.previewdns.com';
(take out the pound sign.)
0
 
nanharbisonCommented:
What are the modules you are trying to install? Can they wait until the main website is finished enough to make it be the live site before you add them?
0
 
Richard KortsAuthor Commented:
Views & something called Features.

No it cannot wait; I have to have the stupid blog working correctly.

I know I can do it by transferring it back to the prior domain I was using to develop it; install there & transfer back. But what a pain.

Richard
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
stephencolsonCommented:
Can you check your settings.php file for the base_url? It might be set to the production server and might be trying to kick you over to its address.
0
 
Richard KortsAuthor Commented:
To stephencolson

There is a settings.php & a default_settings.php.

Both have several definitions of $base_url ALL commented out.

Are you suggesting I might set $base_url to "amcindustries.com.previewdns.com"?

Thanks
0
 
Richard KortsAuthor Commented:
Nan,

I did that. It seems to have NO effect. See attached.
cant-install-views.jpg
0
 
nanharbisonCommented:
Oh man, that stinks. And you are using Drupal to add the module, you know the Add A Module at the top of the modules page?
0
 
nanharbisonCommented:
Try finding the line in the .htaccess file that says:
#RewriteBase /
and take the # out to uncomment it, leaving the base url the way it is.
The htaccess file is in the root directory.
0
 
Richard KortsAuthor Commented:
Nan,

Yes, I am using the Add a Module at the to of the Modules page,

Changed .htaccess uncommenting #ReWriteBase. Will try that RIGHT NOW.

That's the biggest .htaccess file I've ever seen in my life.
0
 
Richard KortsAuthor Commented:
Nan,

Same thing (with modified .htaccess). Note this is the url it is going to when it gets the 404 error:

http://amcindustries.com/authorize.php?batch=1&op=start&id=48

It INSISTS on using amcindustries.com
0
 
nanharbisonCommented:
wow, it's too bad you have to put the ".com" in the preview site, that is what is messing it up.
0
 
Richard KortsAuthor Commented:
You mean the first or the 2nd .com? MAYBE I can get GoDaddy to let it work with only the 2nd.

Should I ask?

Or should I ask at the Drupal forum?
0
 
nanharbisonCommented:
the first one. Aks godaddy first, you can call them and get a faster answer
0
 
Aaron FeledyConnect With a Mentor Drupal Developer and ConsultantCommented:
Just download the module, unzip it, and upload the folder to /sites/all/modules via FTP. You'll then be able to see it on the modules administration page where you can enable it.
0
 
nanharbisonCommented:
Try doing it by going to the module page and at the top is an Add a module link, use that. And right click on the module tar.gz file on the Drupal site and choose copy shortcut:
https://drupal.org/project/views
or use this:
http://ftp.drupal.org/files/projects/views-7.x-3.7.tar.gz
0
 
Richard KortsAuthor Commented:
I called GoDaddy. I bought a new domain that will be pointed to this hosting; it will take maybe 1 - 2 hours to take effect. It is amcindustriesdev.com.

I probably should edit .htaccess and setings.php to reflect this.

Correct?

Then we shall see if that does the job.

It amazes me how many roadblocks Drupal puts in the way of getting things done.

Thanks
0
 
Richard KortsAuthor Commented:
To All,

I was able to install Views doing what Arrow_1 said. The Module page on views is attached. Not sure what I have to do now.
views.jpg
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.