Solved

cisco SPA501G & Dial Plan

Posted on 2013-05-31
12
529 Views
Last Modified: 2014-07-07
I have a problem with Cisco SPA501G with an Asterisk PBX, it happens that after you set up the phone and made ¿¿the first call after any number compose a call is made to the first number always !
On CIsco phone I have this Dial Plan:

(*xx|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)

Thanks.

-
 Salvatore.
log-spa.doc
0
Comment
Question by:sasapix
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
12 Comments
 

Author Comment

by:sasapix
ID: 39210569
even if I try to call an extension of my voip, such as the 200, the call is always addressed to the patton .. this only happens with phones cisco in my network there are other voip phones from other vendors and working properly.

-
 Salvatore.
log-asterisk.doc
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39213834
from this log .. looks like the dial pattern sent may not be what your trunk is looking for.
"-- Called patton4/800447788"  (i don't see a call to ext 200.)

800447788  ,  this is the number being sent to your trunk.   is this a valid number?  

there might be a problem with the cisco phones stripping a number that should be there.

maybe split the dial rules up and test with those phones specific dial patterns to see which work.                                                          
Also,  Check the context that the phone is running under,  there could be other rules running under different contexts.

maybe a simple dial plan could work for you.

[x*].

try this  for your dial pattern on the phone for testing.  Then maybe you can make a more complex dial pattern but why don't you let your trixbox handle that?

http://www.3cx.com/sip-phones/cisco-spa50xg/
0
 

Author Comment

by:sasapix
ID: 39215738
Hi,
I have also tried from another Cisco SPA501G and the same thing happens if I try to call extension 208 in the asterisk log I find:
  - Executing [s @ macro-dialout-trunk: 19] Dial ("SIP/200-09af0f28", "SIP/patton4/08 | 300 |") in new stack
     - Called patton4/08
     - Answered SIP/patton4-b7311960 SIP/200-09af0f28

I used the phone as a dial plan:
[x *].

this only happens with this model cisco, all other phones work properly.

-
 Salvatore.
registration.JPG
dial-plan.JPG
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Expert Comment

by:TechGua
ID: 39216004
Try

•.                   —Wildcard, match any digit entered.



also i see another issue.  why is the call being sent to the patton trunk?

http://radisys.custhelp.com/app/answers/detail/a_id/346/~/how-to-configure-a-dial-plan-for-a-cisco-phone
0
 

Author Comment

by:sasapix
ID: 39216053
with this dial plan (•.) I can not make any calls, to an extension that will do to an external number and can not see to get no request on logic asterisk.
I do not understand why even typing 200 on the cisco phone (200 for calls the extension) it call an external number which of course is shifted to the patton.
it's all so strange !

-
 Salvatore.
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39216163
can you show me the setup for the extension 200 inside your pbx(TrixBox)?
0
 

Author Comment

by:sasapix
ID: 39216177
in attach configuration about extension 200.

-
 Salvatore.
200.JPG
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39234592
have you tried with no dial plan?
0
 

Author Comment

by:sasapix
ID: 39240520
now I'm trying with a phone snom 710 and everything is the same, what other checks can I do to fix it?

sorry I was wrong thread.

-
 Salvatore.
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39251591
Create a new extension.  And try with no dial plan.  I also would like to see your extension.conf as you may have a dial rule we are not seeing.
0
 

Accepted Solution

by:
sasapix earned 0 total points
ID: 39354195
I contacted cisco and has authorized a return of all phones in that series as it is not compatible with sip with asterisk
0
 

Author Closing Comment

by:sasapix
ID: 40179959
phones are not compatible as stated by Cisco Systems
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The point of this post is to give you a copy/paste installation solution to setting up Asterisk 1.6 on Ubuntu 9.04 (or similar) server. # Setup the system apt-get install subversion apt-get install make apt-get install linux-source kernel-p…
Almost all Internet protocol telephones have built-in switches at the back that allow you to connect your personal computer to one port and use the other port to connect your phone to to a Cisco switch.   Why we need to connect the PC to the pho…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question