Solved

Exchange 2010 OWA identifies as the internal server name

Posted on 2013-05-31
8
541 Views
Last Modified: 2013-05-31
When I go to:

mail.ourdomain.com I get an error in Chrome saying that the server is identifying itself as exchange3 which is the actual servers name (exchange3.local.domain.com).

I've been all over the settings like a rash but can't find anything where I can change this.

thanks.
0
Comment
Question by:Letterpart
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39211127
That will be on the SSL certificate. You need to look there to begin with.

Simon.
0
 
LVL 1

Author Comment

by:Letterpart
ID: 39211146
Thanks Simon.

Will look into it.
0
 
LVL 1

Author Comment

by:Letterpart
ID: 39211165
Ah,

I originally created a certificate from within Exchange but looking at IIS I see what looks like a default one called exchange3.

I'm on the case...
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39211243
Self signed certificates generated by Exchange shouldn't really be used in production. Put a trusted commercial certificate on the server with the relevant names and you will not get SSL prompts.

Simon.
0
 
LVL 1

Author Comment

by:Letterpart
ID: 39211248
Sorted.

I created a cert from within IIS, added it, did the bindings (had a problem with the server not coming back up but removed all the https bindings and added the cert one back) and I'm sorted.

This has also fixed Outlook Anywhere so a double bonus there.

Thanks Simon
0
 
LVL 1

Author Comment

by:Letterpart
ID: 39211262
BTW: These are paid for certs rather than johnny no name ones
0
 
LVL 1

Author Closing Comment

by:Letterpart
ID: 39211272
Thanks.

Would have received an A if more info about where to look, ie in IIS7 rather than Exchange.

It was ok for me as I've been through this before but had forgotten. Others may have required more info to make a complete answer.

Thanks anyway.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39211444
You shouldn't have needed to look in IIS. If you did everything in Exchange it would have bound the certificates for you correctly. If you use the SSL wizard in Exchange 2010 to enable the certificate then it will do everything for you.

Simon.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
Find out what you should include to make the best professional email signature for your organization.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the adminiā€¦

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question