OAB is not updating after migration from Exchange 2003 to 2010

I need some help please.

We have migrated from 2003 to 2010 and the OAB in Exchange 2010 SP3 RU6, is failing to update Outlook clients using 2007/2010.
Changes are not being seen on the client side unless we stop using cached mode, or use OWA. I’ve been searching for an answer to this for several hours and feel like I’m getting nowhere, lots of folks appear to have this same problem.
 
The old Exchange 2003 server has been uninstalled from our ORG as we were under the impression that all of our 10 or so public folders had finished migrating over. The old server was turned off for a few of days prior to removal and we did not see any problems during that time, public folders and their contents were available to all users so we thought we were in the clear to proceed…..I do still have some backups available if needed.

This bit is jumping out at me as a potential cause, maybe it’s a golden nugget?
When I go into public folder management and open the system public folders/Offline Address Book I see there are still some entries from the old 2003 server named
“EX:/o=Net Venture Inc/ou=First Administrative Group” and the path points to: \NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\EX:/o=Net Venture Inc/ou=First Administrative Group


I have set logging to high for the MSExchangeSA service, “OAL Generator” and there are events, most of them are informational, but not very helpful.

Event ID: 9320 -OABGen could not generate full details for some entries in the offline address list for address list '\Global Address List'.  To see which entries are affected, set event logging for the offline address list generator to at least medium.

Event ID: 9359 OALGen truncated or dropped properties for entry ‘<redacted>’ in address list '\Global Address List' because they exceeded the configured size limits for the version 4 offline address list.  The affected MAPI ids are:  8008.
- \Default Offline Address List

Event ID: 9359 -OALGen truncated or dropped properties for entry '<redacted>' in address list '\Global Address List' because they exceeded the configured size limits for the version 4 offline address list.  The affected MAPI ids are:  8009.
- \Default Offline Address List

http://support.microsoft.com/kb/908496 indicates that there are some user properties causing this,
MAPI IDs 8008, 8009 and 8cd8 are the ones being reported, and according to the Technet article below they can be ignored. So presumably that is not causing my problem.
http://blogs.msdn.com/b/dgoldman/archive/2009/12/01/please-read-events-9320-and-9359-on-new-installation-of-exchange-2010.aspx
nvtechAsked:
Who is Participating?
 
nvtechConnect With a Mentor Author Commented:
Thanks, I was able to resolve the issue by running.

"Get-ClientAccessServer | Update-FileDistributionService –Type OAB"
0
 
Simon Butler (Sembee)ConsultantCommented:
First - check that the OAB public folders have the Exchange 2010 server set as the replica.
Do you have Outlook 2003 or older in use? If not, then switch the OAB distribution to web rather than public folders.

Force the update through using

get-offlineaddressbook | update-offlineaddressbook

Did you complete all of the steps for removing Exchange 2003, including rehoming the OAB?

Simon.
0
 
I QasmiTechnical LeadCommented:
check the user those who are having problems or listed in event ids.

1) their AD account is activated and not disabled
2) they have a mailbox assigned to them.
3) the mailbox is not disconnected.

check the OAB generation server is set to exchange 2k10

and then try updating the OAB and regenerating the OAB list

if needed then restart the Microsoft Exchange file distribution service,

and check for the OAB events
0
 
nvtechAuthor Commented:
closed
0
 
nvtechAuthor Commented:
With help from another forum I was able to resolve the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.