Solved

How do I edit the Web.Config file for PHP MySQL. .

Posted on 2013-05-31
12
937 Views
Last Modified: 2013-06-17
I installed the PHPMyAdmin and MySQL software using IIS. I get the following error.
HTTP Error 404.13 - Not Found
The request filtering module is configured to deny a request that exceeds the request content length.
This link identifies that there is a file ( setting in the applicationhost.config or web.config file.) to be edited but I have not been able to find either anywhere.
http://www.digitalfaq.com/forum/web-tech/2873-http-error-40413-a.html

Does anyone know what will clear up this problem. I know that the import to the PHPMySQL database is 48 MBs so the limit has been reached. Please let me know where and how I can fix this. Thank you.
IISError.png
0
Comment
Question by:ruavol2
  • 7
  • 5
12 Comments
 
LVL 82

Accepted Solution

by:
Dave Baldwin earned 500 total points
ID: 39212178
Look here http://forums.iis.net/t/1184090.aspx/1 and here http://elijahm.ninjuro.com/2011/08/08/setting-the-upload-limit-of-php-in-iis-7-5/  There are potentially 3 places that may have to be changed to allow larger uploads.  1 or 2 for IIS and maybe 2 in 'php.ini'.  http://www.php.net/manual/en/ini.core.php#ini.post-max-size
0
 

Author Comment

by:ruavol2
ID: 39213978
Okay I went through everything and made changes. Had to download the PHP Manager and followed instructions. Applied the settings requested. So I did the second and third link. The first one I went back and downloaded the Fiddler Tool and I got the same error as above for the import of the file as well as fiddler came back with some results. But I cannot decifer them. Do you see anything that stands out.

This is the link that took me to use the Fiddler Tool
http://blogs.msdn.com/b/webtopics/archive/2009/01/29/how-to-troubleshoot-http-400-errors.aspx
Fiddler2.png
0
 
LVL 82

Expert Comment

by:Dave Baldwin
ID: 39213983
I'm afraid I have no idea what you are doing.  It looks to me like you sent 48MB and got back 5133 bytes.  But that doesn't tell me what you are doing.
0
 

Author Comment

by:ruavol2
ID: 39215043
The first link you sent me at the top of the page here. I went through on the first link on the top of that page shown in my last post above.. Since I have gone through the other two links you provided above and fullfilled the tasks there. I cannot figure out why I am still getting the 404.13 Upload Content Length Too Large. So I went back to the first link you provided above.  and went through its information. This link describes how to fix this.
http://blog.zajon.com/2010/11/iis7-file-upload-content-length-too.html
It describes hoe to fix this in the Web.Config File .........and I cannot find it anywhere searching my entire PC. Says there are two locations where a setting in that file needs a modification.....

Also I put in the PHP.INI file the following
; Maximum size of POST data that PHP will accept.
; http://php.net/post-max-size
post_max_size = 2000M

also in the PHP manager I put the following.
Maximum Post Size 2000M
Upload maximum File Size 2000M
I do not know if this helps but I think I am close but Just not quite there.......? Any help is appreciated. Thank you.
0
 
LVL 82

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 39215131
'Web.config' is not required for IIS to run.  But if it is not there, the default values are used.  You could say that 'Web.config' is needed only when you want IIS to act differently.  'Web.config' is placed in the root folder for the web site and applies only to that website.

This article http://www.webtrenches.com/post.cfm/iis7-file-upload-size-limits seems to tell you what to do.  Especially read the comments.  You may be able to change the IIS upload limit in the IIS manager itself.
0
 

Author Comment

by:ruavol2
ID: 39217121
It keeps talking about the Web.Config file and it seems to be saying to add the following to it. My problem I cannot find a Web.Config file anywhere. I did find an ApplicationHost.config file. If I have to put it in one of those files One I cannot find and two I wonder if it matters where I put it.....?
 
<system.webServer>
        <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="524288000"/>
            </requestFiltering>
        </security>
</system.webServer>

You have been most helpful. In reading the last link you sent I am wondering if you can see what is needed. Otherwise, I am willing to take this offline if you can help me. Dave. I am close I think but I still not able to get past this. I do not have much as I am a small business. But I can send you a gift if you can help me with this. I have spent so many days on this it is killing my business. So if you know how we can connect I will need your expertise. I have a GoToMeeting if you can help please. Thank you.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 82

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 39217182
I can help you here but I have plenty of my own work to do in my own small business.  

Like I said above, 'web.config' is not required for the web site to work.  You may have to create the 'web.config' file with a text editor (Not Microsoft Word) and put that text in there.  Then put it in the root directory for that web site.
0
 

Author Comment

by:ruavol2
ID: 39217293
Wait you were right I looked at the comments a little closer and I may have something testing it now.
0
 

Author Comment

by:ruavol2
ID: 39218217
Ah Crap after I did the modification on the Request Filtering Which showed the Web.Config setting in it. It broke. I also noticed now I have a Web.Config file in the wwwroot folder that showed up. When I changed the settings under REquest Filtering. Then I noticed the Web.Config file was not changing. So I updated both to match the MAXALLOWEDCONTENTLENGTH. because somehow one does not control both. They both have to be independently changed it would seem.
If you want to look at this with me I can honor my request above.
IIS-RequestFiltering.png
IIS-WebConfig.png
0
 

Author Comment

by:ruavol2
ID: 39219884
I was using Http://localhost/PHPMyAdmin/ and after i made the adjustments. Now It will not load the IIS server. Any thoughts on what I could try to figure out what happened and why I cannot even login at this point.
0
 
LVL 82

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 500 total points
ID: 39220121
Put it back the way it was.  I almost never run anything as 'localhost' anymore.  I always use the IP address or domain name.  'localhost' especially on new computers with IPV6 seems to have problems with many things.
0
 

Author Closing Comment

by:ruavol2
ID: 39253434
I got it to work and accept the download file size. Thank you for the support.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Does the idea of dealing with bits scare or confuse you? Does it seem like a waste of time in an age where we all have terabytes of storage? If so, you're missing out on one of the core tools in every professional programmer's toolbox. Learn how to …
These days socially coordinated efforts have turned into a critical requirement for enterprises.
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will learn how to count occurrences of each item in an array.

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now