Solved

public private

Posted on 2013-05-31
12
465 Views
Last Modified: 2013-06-03
in my rc1 machine
the /etc/hosts file is

[root@rc1 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:06:10:4B  
          inet addr:192.168.2.55  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe06:104b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:239 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:35537 (34.7 KiB)  TX bytes:11873 (11.5 KiB)
          Interrupt:67 Base address:0x2024

eth1      Link encap:Ethernet  HWaddr 00:0C:29:06:10:55  
          inet addr:10.0.0.6  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe06:1055/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:223 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:33926 (33.1 KiB)  TX bytes:12572 (12.2 KiB)
          Interrupt:67 Base address:0x20a4

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2060 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2060 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4420688 (4.2 MiB)  TX bytes:4420688 (4.2 MiB)

[root@rc1 ~]#

in my rc2 machine this is /et/hosts

[root@rc2 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:4A:C2:8D  
          inet addr:192.168.2.77  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe4a:c28d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:113 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15131 (14.7 KiB)  TX bytes:10084 (9.8 KiB)
          Interrupt:67 Base address:0x2024

eth1      Link encap:Ethernet  HWaddr 00:0C:29:4A:C2:97  
          inet addr:10.0.0.7  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe4a:c297/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:112 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14531 (14.1 KiB)  TX bytes:10492 (10.2 KiB)
          Interrupt:67 Base address:0x20a4

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1721 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1721 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3570844 (3.4 MiB)  TX bytes:3570844 (3.4 MiB)

[root@rc2 ~]#




This is the model  of rac /etc/hosts file

ok


127.0.0.1       localhost.localdomain   localhost
# Public
192.168.0.101   ol5-112-rac1.localdomain        ol5-112-rac1
192.168.0.102   ol5-112-rac2.localdomain        ol5-112-rac2
# Private
192.168.1.101   ol5-112-rac1-priv.localdomain   ol5-112-rac1-priv
192.168.1.102   ol5-112-rac2-priv.localdomain   ol5-112-rac2-priv
# Virtual
192.168.0.103   ol5-112-rac1-vip.localdomain    ol5-112-rac1-vip
192.168.0.104   ol5-112-rac2-vip.localdomain    ol5-112-rac2-vip
# SCAN
192.168.0.105   ol5-112-scan.localdomain        ol5-112-scan
192.168.0.106   ol5-112-scan.localdomain        ol5-112-scan
192.168.0.107   ol5-112-scan.localdomain        ol5-112-scan


What and where should I add my ip address for rc1 and rc2 for private and public address and scan

Can u please make a real /etc/hosts file for my grid machine..
0
Comment
Question by:walkerdba
  • 5
  • 3
  • 2
  • +2
12 Comments
 

Author Comment

by:walkerdba
Comment Utility
very urgent please thank you....
0
 
LVL 23

Expert Comment

by:savone
Comment Utility
You should add them to /etc/hosts file if you want to resolve the names without DNS.
0
 
LVL 23

Expert Comment

by:savone
Comment Utility
In order to make you a hosts file, I need the following information.

server hostname and IP

for each entry... It is simple you can do it yourself.  Just add lines to the /etc/hosts file for each machine name and IP.  Here is an example line:

192.168.2.55  rc1

Thats it, keep adding lines for each address.
0
 

Author Comment

by:walkerdba
Comment Utility
What is private public and virtual address

etho is private?
etho is public ?

virtual ?

SCAN ?

in the dummy above can you add all these

I gave you the output of ifconfig of both machines  

below..
0
 
LVL 23

Expert Comment

by:savone
Comment Utility
Add this to your /etc/hosts file.

192.168.2.55      rc1
10.0.0.6      rc1
192.168.2.77      rc2
10.0.0.7      rc2
0
 

Author Comment

by:walkerdba
Comment Utility
the dummy is

127.0.0.1       localhost.localdomain   localhost
# Public
192.168.0.101   ol5-112-rac1.localdomain        ol5-112-rac1
192.168.0.102   ol5-112-rac2.localdomain        ol5-112-rac2
# Private
192.168.1.101   ol5-112-rac1-priv.localdomain   ol5-112-rac1-priv
192.168.1.102   ol5-112-rac2-priv.localdomain   ol5-112-rac2-priv
# Virtual
192.168.0.103   ol5-112-rac1-vip.localdomain    ol5-112-rac1-vip
192.168.0.104   ol5-112-rac2-vip.localdomain    ol5-112-rac2-vip
# SCAN
192.168.0.105   ol5-112-scan.localdomain        ol5-112-scan
192.168.0.106   ol5-112-scan.localdomain        ol5-112-scan
192.168.0.107   ol5-112-scan.localdomain        ol5-112-scan



Where exactly in this file we attach the eth0 ?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 19

Expert Comment

by:simon3270
Comment Utility
There is no ordering in /etc/hosts (assuming that all of the IP addresses are unique) - you just add the lines where you want.

The "#Private", "#Public" etc labels are just that - labels used by humans reading this file.  they have no impact on any program using it.

Since neither of your IP addresses (192.168.2.77 or 10.0.0.7) are on the same subnet as any of the exisitng IP addresse in your file, they don't really "belong" in any section.  They are both "Private" addresses in that they won't normally be routed, but that's the case for all of the addresses inyour existing hosts file too.
0
 

Author Comment

by:walkerdba
Comment Utility
Sir my question is etho is private or public
eth1 is public or private please confirm
0
 
LVL 34

Expert Comment

by:Duncan Roe
Comment Utility
According to RFC1918, both eth0 and eth1 have private addresses. By the way, eth0 is E-T-H-NOUGHT - that 4th character is a zero.
That is the question you insisted on having answered. But that answer doesn't tell you whether any Network Interface Card (NIC) is connected to the Internet or an in_house router. One of them would have to be, in order to give access to networks not connected directly to either NIC.
In http:#a39213364, you said you would post output from ifconfig on both systems, but there is no such post. Please post that information now. Also while you are doing that, please add output from ip route list (i.e. post output from ifconfig;ip route list). It might not mean a lot to you, but it will help us give you an answer.
On which subject, what is your actual problem that you need to resolve?
0
 
LVL 21

Expert Comment

by:Mazdajai
Comment Utility
Looking at the ifconfigs, it appears that the servers use eth1 to communicates to other nodes. (private)

Do you have a database server that sits in the 10 subnet?
0
 
LVL 34

Accepted Solution

by:
Duncan Roe earned 500 total points
Comment Utility
My bad, you did post both ifconfigs in the original Q. You have 2 networks: 10.0.0/24 and 192.168.2.0/64. Both machines are connected to both networks. Both networks are private.
Looking at packet numbers in these, at least rc1 has communicated with a system other than rc2 on network 10.0.0.0.
Really need to understand better what is your real question.
0
 

Author Closing Comment

by:walkerdba
Comment Utility
fine
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

I remember the day when someone asked me to create a user for an application developement. The user should be able to create views and materialized views and, so, I used the following syntax: (CODE) This way, I guessed, I would ensure that use…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Via a live example, show how to take different types of Oracle backups using RMAN.
This video shows how to Export data from an Oracle database using the Original Export Utility.  The corresponding Import utility, which works the same way is referenced, but not demonstrated.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now