• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2765
  • Last Modified:

Midas.dll problem in Delphi XE4

Hi,
I use Delphi XE4 for developping on iPad with Firemonkey on Windows 7 64 bit.
On design time I use one SQLConnection for talk wit my datasnap REST server and when I connect is all ok. Next I use one SQLServerMethod connected to SQLconnection and is it active without problems. Next component is one DataSetProvider connect to SQLServerMethod and is all ok.

My problem is when I use one ClientDataset: if i tourn active property to true I receive one message "Error Loading MIDAS.DLL".

Midas.dll is in C:\windows\SyWOW64, in all the directory of my program; I use midaslib in my uses bat non works.

Ideas?

Thanks (and sorry for my english!)
Marco
0
MarcoFerlini
Asked:
MarcoFerlini
1 Solution
 
5xiaoxi2Commented:
uses bat file to register midas.dll
0
 
MarcoFerliniAuthor Commented:
how can I do?
Regards
0
 
ben-thompsonCommented:
midas.dll doesn't need to be registered, you can put it in the same directory as your application.

But also, it isn't actually needed. Recompile the application with MidasLib in the uses clause.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now