Solved

PowerConnect 7024P VLAN DHCP

Posted on 2013-06-01
14
909 Views
Last Modified: 2016-11-23
I have a Dell PowerConnect 7024P that has both VLAN 1 and VLAN 300 configured.  VLAN 300 is used to support VOIP.  The problem I'm having is that for some reason the DHCP server I have setup to allocate IP addresses to the VOIP phones is allocating addresses to the desktop machines.  I'm confused why this would be happening since I did allocate and IP address for each VLAN interface in order to ensure the request would get handled correctly based on the subnet.  So why does the DHCP server for VOIP hand out IPs to the desktop machines?

Voice VLAN 300

VLAN 1
ip address 172.31.25.252 255.255.255.0

VLAN 300
ip address 172.30.25.252 255.255.255.0
0
Comment
Question by:lmehlhorn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
14 Comments
 
LVL 20

Expert Comment

by:woolnoir
ID: 39213744
you have 2 seperate DHCP servers ? or 1 with 2 scopes ? you have probably set up a 'ip helper' statement somewhere to forward DHCP requests to your DHCP server ? if so, i believe (from memory - gong to check now) this switch only supports 1 helper statement for the whole device and not per vlan DHCP like ciscos.

essentially ALL dhcp requests from your vlans will be forwarded to all DHCP servers, so it may be random.

You could probably setup 1 server, 2 scopes, match the networks with your VLAN definitions and have it working fine.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 39213747
somewhere you have these commands right

bootpdhcprelay enable
bootpdhcprelay serverip ip-address

so if you can elaborate on how many DHCP servers you have, 1 per vlan, or 1 for both (with 2 scopes) i can assist further.
0
 

Author Comment

by:lmehlhorn
ID: 39214394
Yes, I have to 2 separate DHCP servers setup.  I don't have the boopdhcprelay commands because I didn't think they would be required with the "ip address" set for each VLAN interface.  The way I understand it when the DHCP request is made the VLAN IP/Subnet will determine which DHCP server/scope to poll.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 5

Expert Comment

by:andrew1812
ID: 39214609
You just need i dhcp server. Create multiple scopes for the network address you want (vlan 1 and vlan 300). Configure the dhcp server with IP address belonging to vlan 1 or vlan 300. If the dhcp server is on vlan 1 configure IP helper address for the vlan 300 interface on the switch r vice versa.
0
 

Author Comment

by:lmehlhorn
ID: 39214712
Okay, I configured a single DHCP server to handle both scopes.  I modified VLAN 300 to have the following configuration.  However, when I plug in the VOIP phone and review the network configuration it still displays the PC subnet 172.31.25.0/24.  I'm assuming that the VOIP phone isn't getting put into VLAN 300 (Voice VLAN) and thus not requesting the correct scope??

interface vlan 300
ip address 172.30.25.252 255.255.255.0
ip netdirbcast
ip helper-address 172.31.25.50 dhcp
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 39214849
What's the port config on the port with the phone plugged into?
0
 

Author Comment

by:lmehlhorn
ID: 39215009
Port is configured as follows based on the running config

interface Gi1/0/1
switchport voice detect auto
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 300 tagged
voice vlan 300
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 39215053
Are they cisco phones ? do they support the voice vlan feature (its not standard across the board...)
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 39215057
if its the only device on the port, then just set the native (normal) vlan to be the VOIP vlan. Voice vlan is only really usefull with device chaining i.e port -> phone -> PC.
0
 

Author Comment

by:lmehlhorn
ID: 39215075
Yes, they are Cisco 7950 phones .  They are not the only device on the port - they are chained eg Phone - PC.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 39215237
So if your problem is that the desktop machines are getting VOIP IP ranges... (as in your original post) you need to specify the non voip vlan on your port ? Set the port vlan to your data VLAN as untagged.
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 39215239
Although i guess since you are using vlan 1 (default) then all ports not defined will be in 1 by default, but since you have set an allowed list, you should add vlan 1 to that port as untagged too. Do that, and check if it alters the result.
0
 

Accepted Solution

by:
lmehlhorn earned 0 total points
ID: 39627692
Firmware upgrade 5.1.0.1 addressed a bug and fixed the problem
0
 

Author Closing Comment

by:lmehlhorn
ID: 39638274
Managed to solve it on my own.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
windows firewall + remote registry/ system 8 41
Erratic mouse/cursor movements  - latency 6 70
Check Spoof email 6 71
MONITOR MANUFACTURING MYSTERY 5 55
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question