Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Remote Desktop Port Forwarding and Opening

Posted on 2013-06-02
12
Medium Priority
?
601 Views
Last Modified: 2014-03-09
Hello,

I am having trouble getting some ports open on my server. I have done a port scan and it keeps timing out on port 3392. I have opened the port on the windows firewall on the inbound settings, as well as our main firewall that we have.

I am using port 3392 because I have a domain and I getting people to access their work stations remotely via RDP. I have two users setup currently from a previous configuration that another tech implemented.

Where else would I have to add port 3392 to get this working and open on the server or network.

Thanks in advance!
0
Comment
Question by:Directtechit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 2
12 Comments
 
LVL 4

Expert Comment

by:jprlopes
ID: 39215144
Normally, RDP uses port 3389.

Maybe you have another setup you need to do in your router?
Or the only firewall you have its the one you configured already?
0
 
LVL 25

Expert Comment

by:clockwatcher
ID: 39215148
RDP typically runs over 3389.  Have you changed the port to 3392?
0
 
LVL 25

Expert Comment

by:clockwatcher
ID: 39215153
Sorry...  didn't see jprlopes comment when I posted.
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 

Author Comment

by:Directtechit
ID: 39215243
I know remote desktop normally uses port 3389. I have different ports being directed to different computers on the network.

Example: I have one port I have on the firewall is 3390, and that is going to 192.168.1.21
Another computer is on port 3391, and that is going to 192.168.1.22

These are already setup and are working. I am trying to setup Port 3392 on the windows firewall for 192.168.1.23 to use and I can't get port 3392 to open all the way on the server and on the firewall. I do a port scan and it still isn't saying it isn't open, or it will time out.

Thanks in advance!
0
 
LVL 4

Expert Comment

by:jprlopes
ID: 39215429
Have you changed the default RDP port in Registry machine, from default 3389 to 3392 port?

By default, all clients are listening RDP from 3389.

In registry:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\PortNumber

Change from 3389 to 3392.
0
 

Author Comment

by:Directtechit
ID: 39216789
I have already done that. It still isn't connecting properly at the moment. For some reason the computer isn't accepting that port and I've changed the listening port already.

I have changed the listening port from 3389 to 3392

Even though I have gone through the windows firewall and opened up the ports as well. It still isn't working right.

Any other suggestions?
0
 

Author Comment

by:Directtechit
ID: 39236581
Would anyone think that it is AVG possibly blocking this from happening?
0
 
LVL 4

Expert Comment

by:jprlopes
ID: 39236853
Could be, but normally he dont.
0
 

Author Comment

by:Directtechit
ID: 39236911
Is there a reason why the computers listening port wouldn't change or register?

Thanks again
0
 
LVL 4

Expert Comment

by:jprlopes
ID: 39239542
But the Registry made in port number mantains?
Or changed to 3389 again, after you changed to 3392?
0
 
LVL 4

Accepted Solution

by:
jprlopes earned 2000 total points
ID: 39239572
How about you you õnly made Port fowarding in router, but mantain all client ports to default 3389?

You can create 3 fowardings:

IP:3390 -> 3389 of PC1
IP:3391 -> 3389 of PC2
IP:3392 -> 3389 of PC3

You still have security, because if someone tries to acess RDP from outside, without knowing the correct ports, will fail.
0
 

Author Comment

by:Directtechit
ID: 39243548
That is the idea of what I am trying to do. I appreciate all the comments guys.

I have an idea, let's start from the beginning. The port 3392 isn't open on my server. I have tried to open it many times, but it is not opening properly. Any ideas?
0

Featured Post

ATEN's HDBaseT Presentation at InfoComm 2017

Hear ATEN Product Manager YT Liang review HDBaseT technology, highlighting ATEN’s latest solutions as they relate to real-world applications during her presentation at the HDBaseT booth at InfoComm 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
Like many organizations, your foray into cloud computing may have started with an ancillary or security service, like email spam and virus protection. For some, the first or second step into the cloud was moving email off-premise. For others, a clou…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question