• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 527
  • Last Modified:

can't see other computers on newly installed 2012 windows server

I just installed a new 2012 windows server as a domain server.  Things seemed to go ok, but after I joined the Win 8 workstations, the workstations do not show the server in the "network" and the server also does not show the workstations.  I can remote desktop both ways and I can ping both ways, so I don't think it is a bad cable.  

Any help is appreciated.
0
ken_b
Asked:
ken_b
  • 6
  • 3
  • 2
1 Solution
 
mstickler1Commented:
Is the 2012 server setup as the the primary dns server on the server and the clients?
0
 
bigeven2002Commented:
Hello,

In addition to the DNS setting above, is network discovery turned on for the 2012 server and workstations?  Also, if you have the firewalls on for both the server and workstations, make sure the exception is enabled for file and print sharing.  

You might also have to start the Computer Browser service on the 2012 server.
0
 
ken_bAuthor Commented:
I believe that the server is setup as DNS for both the server and the clients.  Setting up the server DNS was a requirement of the 2012 server configuration in order to configure the server as a domain server.  I had to make the clients use the server DNS in order to connect them to the domain.  

I did turn on the network discovery on both, but of course I will double check that tomorrow.  

I have not looked at the firewall settings of either the server or the client's firewall.  I will look for the firewall exception that you mentioned, tomorrow evening.  That could be it.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
bigeven2002Commented:
Sounds good, let us know the result.  

Also, it may not be necessary but you might enable WINS on the server too and have DHCP specify the WINS address to the Workstations or assign it manually if they are static.
0
 
ken_bAuthor Commented:
I am running DHCP at the router, and I don't think on the server as my understanding was that also running DHCP on the server would conflict.  I'm not familiar with WINS.  Are you suggesting that I would activate the WINS service on the server but enter the WINS address given (wouldn't it just be the server's ip address) into the router?, or into each workstation?

Sorry to be so confused.
0
 
bigeven2002Commented:
Correct, activate the wins service on the server and the wins address is the same as the server address.  So the router will serve it from its dhcp so that the workstations will know that the server is also a wins server.  However, I am not sure how to tell the router to specify a wins address unless it has a wizard or template on it that can guide you.  If the router is unable to specify wins then I think you would have to enter it manually on the workstations in the network adapter tcpip properties.
0
 
bigeven2002Commented:
Another thought occurs, can you also make sure that on both e the server and
Workstations that net bios over tcpip is enabled?  It is also in the network adapter properties for tcpip v4 > advanced > wins tab
0
 
ken_bAuthor Commented:
It was this last thought about the net bios over tcip enabe that fixed it.

Many thanks for all your help bigeven2002!
0
 
mstickler1Commented:
Just an FYI,
Depending on who you talk to, netbios over tcpip is anything from a security risk, to old tech, to the best thing since sliced bread. Ditto with WINS (think of it as DNS for netbios names.) In your case it resolved your issue but it should be noted that if everything with your tcpip configuration is correct (as in, setup the way MS expects them to be) then you should be able to see your network computers without enabling it.

I suspect the issue is with DHCP running on the router. I would bet the router is supplying either its own address or the isp's DNS server addresses to the clients as the DNS server for the clients to use. If it were me I would disable the DHCP server on the router and enable it on the server. If you do so you will need to make sure DNS root hints or DNS forwards are configured properly http://technet.microsoft.com/en-us/library/cc754941.aspx so your clients can see the outside world.

If you do a search on DHCP on the Domain Controler you will get a lot of "No don't it's a performance issue, or no don't it's a security issue: but I will guarantee those arguments are about windows 2003 or earlier.

As an alternative you could leave DHCP on the router but make sure it is supplying clients with the server as the DNS server. How you do this varies by manufacturer but it will be under the DHCP settings or the LAN settings.

I know it is working at the moment but if network performance is an issue I seriously consider getting rid of netbios as it generates a lot of broadcast traffic.
0
 
bigeven2002Commented:
No problem, glad that worked!
0
 
bigeven2002Commented:
Thanks for the information mstickler1.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 6
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now