Solved

FTP , IIS 6 , operation time out

Posted on 2013-06-03
5
1,018 Views
Last Modified: 2013-07-22
Server 2003 , FTP server.
Some users complain that they see "operation timed out" when download big files.
I would appreciate guidance where I need to change that setting.
Thank you.
0
Comment
Question by:D_Batona
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 10

Expert Comment

by:gaurav05
ID: 39218497
Hi,

Set Passive FTP connection on your ftp server.

For how to setup passive FTP check below link

http://www.iamiraqi.com/forum/forum_posts.asp?TID=3679
http://www.velikan.net/iis-passive-ftp/

Let us know if you still not able to resolve issue.
0
 

Author Comment

by:D_Batona
ID: 39219271
It is set on server. Let me check what connection client opens for that particular user.
Thank you.
0
 

Author Comment

by:D_Batona
ID: 39229480
The solution partially works.
The client used FileZilla client in passive mode.
It started working without problem only when he checked "Send FTP keep-alive commands" in FileZilla settings.
I guess that something needs to be changed in server  settings.
I would appreciate your comments.
Thank you.
0
 

Accepted Solution

by:
D_Batona earned 0 total points
ID: 39323788
So As I did not get any response I had to do my own research.
Here is the explanation taken at FileZilla Wiki but it is related to any client behind the router no matter passive or active mode is used:


https://wiki.filezilla-project.org/Network_Configuration

 Timeouts on large files

If you can transfer small files without any issues, but transfers of larger files end with a timeout, a broken router and/or firewall exists between the client and the server and is causing a problem.

As mentioned above, FTP uses two TCP connections: a control connection to submit commands and receive replies, and a data connection for actual file transfers. It is the nature of FTP that during a transfer the control connection stays completely idle.

The TCP specifications do not set a limit on the amount of time a connection can stay idle. Unless explicitly closed, a connection is assumed to remain alive indefinitely. However, many routers and firewalls automatically close idle connections after a certain period of time. Worse, they often don't notify the user, but just silently drop the connection. For FTP, this means that during a long transfer the control connection can get dropped because it is detected as idle, but neither client nor server are notified. So when all data has been transferred, the server assumes the control connection is alive and it sends the transfer confirmation reply. Likewise, the client thinks the control connection is alive and it waits for the reply from the server. But since the control connection got dropped without notification, the reply never arrives and eventually the connection will timeout.

In an attempt to solve this problem, the TCP specifications include a way to send keep-alive packets on otherwise idle TCP connections, to tell all involved parties that the connection is still alive and needed. However, the TCP specifications also make it very clear that these keep-alive packets should not be sent more often than once every two hours. Therefore, with added tolerance for network latency, connections can stay idle for up to 2 hours and 4 minutes.

However, many routers and firewalls drop connections that have been idle for less than 2 hours and 4 minutes. This violates the TCP specifications (RFC 5382 makes this especially clear). In other words, all routers and firewalls that are dropping idle connections too early cannot be used for long FTP transfers. Unfortunately manufacturers of consumer-grade router and firewall vendors do not care about specifications ... all they care about is getting your money (and only deliver barely working lowest quality junk).

To solve this problem, you need to uninstall affected firewalls and replace faulty routers with better-quality ones.
0
 

Author Closing Comment

by:D_Batona
ID: 39345087
Probably No experts in this field , fixed it myself.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
HTTP to HTTPS but have 2 sub sites 8 47
logs for inetpub time stamps are off 1 36
Bot attack question 11 84
PHP 5.6 and 7.x 4 52
Logparser is the smartest tool I have ever used in parsing IIS log files and there are many interesting things I wanted to share with everyone one of the  real-world  scenario from my current project. Let's get started with  scenario - How do w…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question