Solved

URGENT HELP NEEDED!  user files not showing up after changing domains!

Posted on 2013-06-03
9
162 Views
Last Modified: 2014-08-20
I switched from 2 DCs (one being on a 2003 server the other on a 2008R2 server) to 1 DC (2008R2).  A new domain was created on the new 2008R2 box.   Among other things, I copied over using robocopy 2 file directories.  One was "general files" the other was "user shares" (permissions on "personal shares" is system, admins and the user of the share).  After the switch and files were put on new server "general files" were accessed fine by the new user accounts that were set up.  ***However, the "user shares" directory is showing EMPTY both on the new server and the old server even though if I look at the properties of the root folder it says the data is there!!!  When I try to recover from a backup that is a week old, that folder still shows empty!!!!!!

Any help on this would be GREATly appreciated.
0
Comment
Question by:ImImIn
  • 4
  • 4
9 Comments
 
LVL 27

Expert Comment

by:davorin
ID: 39216759
Have you checked the folder permissions? If you can't manage permissions try to take the ownership of the folder.
0
 

Author Comment

by:ImImIn
ID: 39216780
Yes I have checked the folder permissions and everything seems to be in good order?
0
 
LVL 2

Expert Comment

by:Wouter Makkinje
ID: 39216990
This might seem stupid but:

Have you enabled viewing hidden files and folders?
Are you running Access based enumeration on the share leaving it visibly empty unless your actual account has the proper rights on all folders?
Access-based enumeration (ABE) displays only the files and folders that a user has permissions to access. It is a feature that was previously available as a downloadable package for the Windows Server 2003(but included from SP1). Access-based enumeration is now included in the Windows Server 2008, and you can enable it by using Share and Storage Management for the share were you want to enable it.
Read more about it here: http://havardkristiansen.com/?p=152

What you are describing sounds exactly like a case of ABE but i can't know if you're actually using an account with the permissions granted or not.

To see if ABE is active

1.

Open Administrative tools: Share and storage management

2.

Right-click your share and select properties

3.

Notice the field Access Based Enumeration and if it is set to Active or Inactive.I hope this helps a little let me know what turns up, feel free to attach screen shots of the ACL's so we may be able to help you better.

Oh also, if you know the name of the folder try running the following command in an elevated command prompt:

attrib -r -h -s "G:\folder_name"

Replace the Drive letter and folder name with your drive letter and folder name such as D:\Usershare
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ImImIn
ID: 39217064
Thanks for your replies!  I have enabled viewing hidden files and ABE is disabled.  Remember this sam bizarre problem is both on the old and new servers.  The old server did not have this problem prior to the switch over!
0
 
LVL 2

Expert Comment

by:Wouter Makkinje
ID: 39217089
Did you run attrib -r -h -s "path" ?
0
 

Author Comment

by:ImImIn
ID: 39217178
yes, no luck.
0
 
LVL 2

Accepted Solution

by:
Wouter Makkinje earned 500 total points
ID: 39218336
Hmmn i have further searched for this and have stumbled across that this should work since robocopy sets the destination to system:

attrib -h -s -a [ Drive : ][ Path ].

For example: attrib -h -s -a "C:\My hidden folder"

Please give this a try as its a tad different then what i wrote earlier.

Also you can try this:

The problem is that for whatever reason, Robocopy has marked the directory with the System Attribute, making it invisible in the directory structure unless you enable the viewing of system files. The easiest way to resolve this is through the command line. Open a command prompt and change the focus to the drive in question (e.g. x:) then use the command [dir /A:S] to display all directories with the System attribute set. Locate your directory name and then enter the command [ATTRIB -R -S x:\MyBackup /S /D] where x:\ is the drive letter and MyBackup is your directory name, the /S re-curses subfolders and /D processes folders as well. This should clear the Read Only and System attributes on all directories and files allowing you to view the directory normally.
0
 

Author Comment

by:ImImIn
ID: 39225488
Thanks for your help guys!  It ended up being 'who know'!  After changing permissions around a bit (actually a lot!), content was found in the folder structure!  This was very frustrating!
0
 
LVL 2

Expert Comment

by:Wouter Makkinje
ID: 39228248
Great that it worked out for you! :D
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you upgrade from Windows 8 to 8.1 or to Windows 10 or if you are like me you are on the Insider Program you may find yourself with many 450MB recovery partitions.  With a traditional disk that may not be a problem but with relatively smaller SS…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question