• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 530
  • Last Modified:

procmail not running .procmailrc file

We just moved onto a new server running Redhat Enterprise 6.3

I can't figure out why my .procmailrc file doesn't get run.  Everything appears to be the same as it was on the old server.

I don't think the problem is with procmail.
I added a VERBOSE=yes and a LOGFILE=tmp to .procmailrc

When I run a test:
procmail DEFAULT=/dev/null VERBOSE=yes .procmailrc </dev/null
the log file tells me that it processed the .procmailrc file.

So I suspect the problem is with sendmail but that looks correct as well.

The permissions on my home folder are 700 and the permissions on my .procmailrc file are 600  So I don't think this is a permissions issue.

The relevant lines in the sendmail.mc file are:

FEATURE(local_procmail,`/usr/bin/procmail',`procmail -t -Y -a $h -d $u')dnl


I've run m4 to get it into the sendmail.cf file which has the following lines:
Mprocmail,      P=/usr/bin/procmail, F=DFMSPhnu9, S=EnvFromSMTP/HdrFromSMTP, R=EnvToSMTP/HdrFromSMTP, A=procmail -Y -m $h $f $u

Mlocal,         P=/usr/bin/procmail, F=lsDFMAw5:/|@qSPfhn9, S=EnvFromL/HdrFromL, R=EnvToL/HdrToL, A=procmail -t -Y -a $h -d $u

When I send an email to my account it gets delivered to /var/spool/mail instead of getting processed by my .procmailrc file

There's nothing in /var/log/maillog to lead me to suspect anything is wrong.
Jun  3 12:08:58 [myhostname] sendmail[15653]: r53J8vRX015651: to=<geekdad1@mm.ca>, delay=00:00:01, xdelay=00:00:01, mailer=local, pri=37253, dsn=2.0.0, stat=Sent

We're running selinux on this machine.  That's the one big difference.  Is there any of those config options I need to set?

I'm at a loss what to look for now.  If anyone could spot the problem or point me in the right direction I would appreciate it.
  • 3
  • 3
1 Solution
Have you trying putting selinux in permissive?
setenforce 0 

Open in new window

Have you check where is your default procmail that points to? I have seen it look at /var/spool/mail/$username instead.

How you config and setup the new server? You may want to compare the environment with the old server.
geekdad1Author Commented:
Yep, definitely selinux.  With enforce turned off, it works.

does anyone know the policy needed for sendmail/procmail?
Can you post the output -
ls -laZ .procmailrc

Open in new window

Have you check /var/log/audit/audit.log - it should give you an idea.
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

geekdad1Author Commented:
there's absolutely nothing in the audit.log with the word mail in it.  So that was no help.

-rw-------. mailacct mgdsrvcs unconfined_u:object_r:home_root_t:s0 .procmailrc
You can use restorecon or chcon to restore the fie context. eg

restorecon -Rv .procmailrc 

Open in new window

geekdad1Author Commented:
changing the context on the .procmailrc file (and some other files) fixed the problem.  Thanks
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now