server 2012 can't check enable branchcache on file share

We have a vpn across the other side of the country, and we now have 2012 file servers on both sides of the network.  There are slow access times when it comes to searching for files, so I thought I might try the branchcache feature on server 2012.  On our newest server that is remote to us, I can go into, the share, and check or uncheck the box that says enable branchcache, which is right below allow caching of share.     On our local server, the same features are installed, however when I do a properties of the share "enable branchcache on the file share is greyed out where I cannot check it.  I have uninstalled the feature and reinstalled the feature and rebooted inbetween to no avail.   does anyone out there have any idea?

thanks
microwebmarkAsked:
Who is Participating?
 
Rob StoneConnect With a Mentor Commented:
I can only reproduce that screen when 'BranchCache for Network Files' is not installed.

I would look at reinstalling that Role and if this doesn't work a reboot.

If that still doesn't fix it then you could extract the binaries from the CD to a shared location, remove the binary for that Role and re-install the binaries from the share.

Step1
To install the binaries use DISM (Deployment Image Servicing and Management tool) to first identify what index matches your OS (from the list)
DISM /Get-Wiminfo /wimfile:D:\sources\install.wim (presuming D is your DVD ROM with 2012 CD in)

Step 2
Remove the existing binaries
Uninstall-WindowsFeature FS-Branchcache -remove

Step 3
Install binaries to a path
DISM /Mount-Wim /Wimfile:D:\sources\install.wim /index:%step2version% /mountdir:C:\Data\Binaries /readonly
Replace %step2version% with the Index number, so index:4 for example.

Step 4
Reinstall the binaries
Install-WindowsFeature FS-BranchCache -source %path of Windows\WinSxS folder
0
 
Rob StoneCommented:
Is Hash Publication enabled on that file server that is greyed out?

Policy location is
Computer Config\Policies\Admin Temp\Network\Lanman Server

Link to enable this:
http://technet.microsoft.com/en-us/library/ee649159%28v=ws.10%29.aspx
0
 
microwebmarkAuthor Commented:
ok.. I went through these steps and it's still greyed out.  perhaps I need a reboot?
did a screen shot below.

thanks
branchecachepic.JPG
0
 
microwebmarkAuthor Commented:
I have tried reinstalling the role, and rebooting, and still got the same results.  I will go ahead and try the binaries solution.  I am closing out my account because I have working for another company now, and I want them to pay for this service instead of me.  I'll find this question using my new account and go from there.   Thank You for your time.

Mark
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.