Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 388
  • Last Modified:

Editing SNMP trap frequency in ESXi 5.0

Hi, we're currently getting a lot of these messages from our ESXi hosts since turning on SNMP traps -

vmware.vmwProductSpecific.30.3.0

I've scoured the vmware forums and it looks like we need to edit the file /etc/sfcb/sfcb.cfg. However I'm unable to get to that file through SSH. It tells me access is denied. So I tried installing the vCLI but i can't work out how to connect to the ESXi host in order to edit the file.

Is there anyone that's able to help?

Many thanks in advance.
0
afl_it
Asked:
afl_it
  • 6
  • 6
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Are you using the FREE or Licensed version for ESXi?

see here you can also change, Filter out the trap

http://communities.vmware.com/thread/417164?start=0&tstart=0
0
 
afl_itAuthor Commented:
We're using the licensed version.
I found that page earlier but can't work out how you connect to a server in order to run the edit command at the bottom. Any ideas?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
vicfg-snmp --notrap  1.3.6.1.4.1.6876.4.90.0.401

VMware KB: Configuring SNMP Traps for ESXi/ESX 3.5, 4.x, and 5.0

you can download and install the vSphere CLI from:

https://my.vmware.com/group/vmware/details?downloadGroup=VCLI50U1&productId=268

vicfg-snmp.pl --server hostname --username username --password password --show
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
afl_itAuthor Commented:
Everything has been setup as per the link you sent but i was wondering if there's a way to change the frequency of the traps.

I found the below but can't work out where to enter the command in the first place!

Edit /etc/sfcb/sfcb.cfg
add
heartbeatInterval: <seconds>
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
you need to login to the server via the console or ssh (remotely).

and use vi

e.g

vi /etc/sfcb/sfcb.cfg

if you do not know of to use vi, you can use WinSCP from Windows.
0
 
afl_itAuthor Commented:
Ok, I've entered that line into the sfcb.cfg file using vi through SSH but it doesn't seem to make any difference.

To test I set the interval time to 30 seconds but they still come every 5 minutes. I've disabled and reenabled the SNMP agent too.

Is there another setting somewhere?

Thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you restart the host?
0
 
afl_itAuthor Commented:
No. I did this -

vicfg-snmp.pl --server <hostname> --username <username> --password <password> --disable
Enabling agent...
Complete.

vicfg-snmp.pl --server <hostname> --username <username> --password <password> --enable
Enabling agent...
Complete.

Is that not enough? Does the heartbeatInterval line need to be put anywhere in particular within the sfcb file? That's all i can think it'd be.

Thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
other than editing the file is not supported, as long as it's in the file.
0
 
afl_itAuthor Commented:
It's strange because no matter what value i put into the line it seems to ignore it. Do you think i need to restart the whole host in order for it to take effect? Seems a bit drastic!

Thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
At a convenient time, I would certainly try restarting the host.
0
 
afl_itAuthor Commented:
Unfortunately finding a convenient time to restart the host is going to be pretty hard to do. Are there any other suggestions out there?

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now