Solved

Crystal reports - parameter decimal positions

Posted on 2013-06-04
4
777 Views
Last Modified: 2013-06-05
I want the users to be able to enter a parameter of .005 (or whatever it will be). The number would always have 3 decimal positions. When this is entered it comes in as .01. How can this be corrected?
0
Comment
Question by:qbjgqbjg
  • 2
4 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 39219838
How do you know it comes in as 0.01?

Drop it on the report
Right click it
Click FORMAT OBJECT
Choose a format with at least 3 decimals or use CUSTOM

If you choose to customize
Set decimals to 1.000 and rounding to 0.001

mlmcc
0
 

Author Comment

by:qbjgqbjg
ID: 39219932
I had already tried that. It shows as 0.010 when formated with 3 decimal positions.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 39220366
Did you also change the rounding?

mlmcc
0
 
LVL 34

Accepted Solution

by:
James0628 earned 500 total points
ID: 39221604
If you put the parameter on the report and change the decimals and rounding for that field to 3 places, then if you enter .005, you should see .005 on the report.  That works here.

 However, if you refresh the report, the parameter screen may round that to .01, and if you don't change it back to .005, the report will get the rounded value (.01) when it refreshes.

 When you run reports from CR 10, the format for number parameters comes from the default number format in CR.  I'm guessing that CR XI is the same.

 If you're running the report from CR, instead of a viewer or some other app, go to File > Options, select the Fields tab and click Number.  Select the Number tab and change the number of decimals and rounding there to 3, then OK your way out of those screens.  The next time you refresh the report, the parameter should show 3 decimal places.

 The problem is that you're changing the default that will be used for all number parameters and new numeric field formats in every report.  When you run any report with a number parameter, it will have 3 decimal places, and when you add a numeric field to a report, it will default to having 3 decimal places.  But that's the only way I know to change the parameter format.

 James
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now