Solved

Connecting a Cisco 3845 router to a Brocade FCX648S switch

Posted on 2013-06-04
11
753 Views
Last Modified: 2013-06-11
Hi,

   Going to be configuring a Cisco 3845 router from interface FastEthernet1/7 to a Brocade on interface ethernet 1/1/1. My question is, would the configs below function?:

Cisco:
interface FastEthernet1/7
 description <== XXXXXXXXX ==>
 no ip address
 switchport
 switchport trunk native vlan 1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan XXXXXXX
 switchport mode trunk
 duplex full
 speed 100
 no spanning-tree portfast
 logging event link-status
 snmp trap link-status
 cdp enable
 no shutdown

Open in new window


Brocade:
interface ethernet 1/1/1
 port-name XXXXX
 speed-duplex auto
 snmp-server enable traps link-change
 enable

Open in new window


Particularly concerned about any speed/duplex issues that may arise - this is a 100M speed / ethernet cable between them, thanks.
0
Comment
Question by:Networking_Enthusiast
11 Comments
 
LVL 2

Expert Comment

by:adembo
ID: 39220620
If you set the speed as 100 on the cisco, you need to do the same on the Brocade. CRC errors will be happening if the speeds are different.

Duplex same thing. Dont have one set static and one set auto. At least in my experience, that is when I see errors in the stats.

So are you also specifically asking about the config you have shown? You have the Cisco set up as trunk port, but you've not mentioned the need to have VLAN's setup on the brocade. No trunking needed if its not going to carry its own VLANs that the Cisco would be aware of.
0
 
LVL 3

Author Comment

by:Networking_Enthusiast
ID: 39220730
I am asking specifically about the config shown, also the Brocade will be passing the VLAN's up to the Cisco router, all that is depicted is the two connecting interface configs (as you could prob. tell). Now with the Brocade being set to auto, and the Cisco to full, would the Brocade sync up with the Cisco appropriately while avoiding errors?
0
 
LVL 3

Author Comment

by:Networking_Enthusiast
ID: 39220733
Wanted to add - by "passing the VLAN's" I mean, the Cisco and Brocade have the same VLAN's configured on them, just the VLAN configs are not depicted here.
0
 
LVL 11

Expert Comment

by:naderz
ID: 39221130
Networking_Enthusiast:

Firstly, please note adembo comments on speed/duplex above: both sides MUST be configured the same. Regardless of the manufacturer. Either both on auto speed and auto duplex or manually configured. The reason is that when an ethernet interface is manually configured for speed and duplex it will not respond to negotiation messages from an interface configured for auto. The interface configured for auto not receiving any replies for its negotiation messages will configure itself for half-duplex assuming the worst! Therefore, all the CRCs and runts errors.

Secondly, you do need the proper Brocade "tagging" and "untagging" of the interfaces. I don't see that. The interface connecting to the Cisco switch needs to be "tagging" the Vlans you want carried over.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 28

Expert Comment

by:Jan Springer
ID: 39221727
I don't see where you've added that port as tagged to any vlans on the Brocade.

Please post a "show run" excluding any login/password info on both.
0
 
LVL 9

Expert Comment

by:DanJ
ID: 39225367
here is the relevant information regarding VLANs allowed on the interface :

Cisco
interface <interface-name>
switchport trunk allowed vlan A-B
switchport trunk native vlan <untagged vlan>

Brocade

vlan A
tagged inteface <interface-name>

vlan B
tagged inteface <interface-name>

interface <interface-name>
dual-mode <untagged vlan>
0
 
LVL 3

Accepted Solution

by:
Networking_Enthusiast earned 0 total points
ID: 39226887
Thanks guys, got my question answered. If the Brocade is set to auto and the Cisco is set to 100 or something else than the Brocade will negotiate to the appropriate speed and the link should function.
0
 
LVL 2

Expert Comment

by:adembo
ID: 39226899
Yes, it will work if you have the speeds different, thats not what I said. What I said was that you may see CRC errors in the interface stats as it tries to negotiate the speed on one end and its hard set on the other. My suggestion was to have it the same on both ends to prevent that, not saying it wouldnt work.
0
 
LVL 3

Author Closing Comment

by:Networking_Enthusiast
ID: 39237143
This is the solution.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now