[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 374
  • Last Modified:

Microsoft Exchange 2003 Decomissioning

A previous Networkin Admin setup Exchange Server 2010 in addition to the Exchange Server 2003 that was already in place. I want to get rid of the Exchange Server 2003 and was working on steps to removing it using msexchange.org. I followed all steps and got to the point where I was deleting the routing group connectors on the 2003 box. As soon as I deleted the Routing Group Connector from the First Administrative Group, I was unable to get mail from the outside. Also,  I was able to receive mail to the outside and have everything work internally without issue though.

Does anyone have idea what I could be missing? Thanks in advance for your help!


Elvir
0
sweeneym
Asked:
sweeneym
  • 10
  • 6
1 Solution
 
Simon Butler (Sembee)ConsultantCommented:
You need to ensure that SMTP traffic is pointing at Exchange 2010 (NAT on your firewall) and you have Anonymous enabled on the Default Receive Connector. That is all that is required.

Simon.
0
 
sweeneymAuthor Commented:
There is 2 receive connectors and the only difference is the FQDN he set. Looks like one is external webmail.XXXX.org and one is internal emailsvr.XXXX.org.  Both have Anonymous checked.

It's possible the Cisco ASA 5510 needs to allow SMTP to the Exchange 2010 server.

I'll take a look at that tomorrow. Thanks!
0
 
Simon Butler (Sembee)ConsultantCommented:
You shouldn't have Anonymous enabled on the Second connector, which should be called "Client Receive Connector" (unless modified). One should be listening on port 25 (Default) and the other on 465 (Client).

The Cisco ASA should also have fixup SMTP disabled on it.
http://semb.ee/fixupsmtp

Simon.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
sweeneymAuthor Commented:
The external connector has port 587 and the internal has port 25 set. Looks like this may be set incorrectly.

I'm assuming Fixup is already disabled on the ASA since the Exchange 2003 box is behind it also.
0
 
Simon Butler (Sembee)ConsultantCommented:
I would check FIXUP SMTP anyway. It doesn't have to be disabled for Exchange to work, but I have seen odd results when it isn't.

Simon.
0
 
sweeneymAuthor Commented:
**UPDATE**  6/5/13 11:24AM EST
ESMTP was enabled on the ASA and I disabled it. I then removed the RGC on the 2003 Exchange server and changed the port from 587 to 465 and so far it's eaxactly like yesterday where I can't get mail from the outside but I can send email to my gmail account without issue.

I do understand that these changes my take awhile and might not work immediately. I've seen many instances of changes working hours later.
0
 
Simon Butler (Sembee)ConsultantCommented:
From an external server you need to telnet in and see what server answers. Whether it is Exchange 2003 or 2010. Once you know that then you can start tracking what Exchange is doing with the message.

Simon.
0
 
sweeneymAuthor Commented:
Sembee2,
Can you elaborate on your last post? I don't 100% get what you are saying.
0
 
sweeneymAuthor Commented:
I tried from the outside to do a "telnet webmail.xxxx.org 25" and I did the same for port 587 and got a 220 response from both. So it looks like the ports are working properly, right?  I think that's what you were asking before.

How can I see what server is responding through telnet?

Also I noticed the MX record of the old 2003 Exchange Server is higher on the list than the Exchange 2010 server. Should I switch that around?
0
 
sweeneymAuthor Commented:
Received: from mail.xxxx.org (192.168.11.251) by emailsvr2.xxxxx.org
 (192.168.11.79) with Microsoft SMTP Server id 14.1.218.12; Thu, 6 Jun 2013
 09:58:07 -0400
Received: from mail-vb0-f45.google.com ([209.85.212.45]) by mail.xxxx.org
 with Microsoft SMTPSVC(6.0.3790.4675);       Thu, 6 Jun 2013 09:57:06 -0400

Above is what a message header looks like. It's hitting the old email server first then being handing over to the new server.
0
 
Simon Butler (Sembee)ConsultantCommented:
With regards to the MX records, I would remove the record that is pointing at Exchange 2003 completely. Only have the single record pointing at Exchange 2010.

The 220 response is expected, it is HOW it answers that allows you to tell which server is answering.

Simon.
0
 
sweeneymAuthor Commented:
Yeah it's what I thought. The MX record for the old server has a higher priority and when the server is on the mail is still going to it but staying  at the old server because i'm removing the connector. Once I turn off the server physically the email is actually working correctly.  

Issue resolved. Thanks for all your help Simon!
0
 
sweeneymAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for sweeneym's comment #a39227001

for the following reason:

Sembee2 provided the correct answer
0
 
sweeneymAuthor Commented:
All set!
0
 
Simon Butler (Sembee)ConsultantCommented:
No points for my answers then?
0
 
sweeneymAuthor Commented:
I thought I did? I apologize if I didn't.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 10
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now