• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1398
  • Last Modified:

GPO with trusted sites grayed out

Hello All:

Details:  Our company has an local sharepoint site ( https://example.company.com ).  We currently use SSO/ActiveSync for logon to workstations that allow users to connect automatically to Outlook for email.  Now it's time to do the same with Sharepoint. I found the GPO setting to add our website to the trusted sites but now no user can add to the trusted sites.
All users using Windows 7 - 64 Bit

Problem:  Trusted sites grayed out & no users can add to the trusted sites since the GPO is currently set.

GPO settings:  Computer Configuration | Administrative Templates | Windows Components | Internet Explorer | Internet Control Panel | Security Page
Site to Zone Assignment List >>> https://example.company.com > Value: 2

Is there a registry key(s) I can edit for users to still add other Trusted Sites ?
Is there any other GPO settings I can manage ?

Thanks for your help. Hope I didn't lose you
  • 5
  • 3
  • 2
2 Solutions
Haresh NikumbhSr. Tech leadCommented:
When we configure Site to Zone assignment list GPO then users will not be able to add their own sites to any zone. Options to add sites on client machine will be greyed out.

the only option is you have add those sites on the same policy

synertiaAuthor Commented:
the only option is you have add those sites on the same policy

I can not keep updating the policy for every Trusted Site with all the DoD sites that users go to. Maybe that is an decision for upper management. But for now, No reg can do this through GPO >?
Haresh NikumbhSr. Tech leadCommented:
Remove the computer gpo and apply it thru the "Internet Explorer Maintenance" policy under User configuration.

Same issue is reported earlier

please refer this link


All Credit goes to dstewartjr  :)
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

synertiaAuthor Commented:
Well yes that is an partial solution but NOT for IE10 users.  

IE10 Internet Maintenance disappears

i think I'm stuck ... unless I do it manually...
I had to do this in an environment myself not to long ago.
I documented it on my own page - check out the last entry on this page:

synertiaAuthor Commented:

that worked great but now the issue is SSO only works for IE 64-bit.  Most users in the office don't know the difference between IE 32 & 64.  Any work around ?
There is a setting in IE option under the advanced tab about passing user credentials. Do you need that in a registry setting also?
synertiaAuthor Commented:
IE 32 bit sees the 'automatic logon with current user & password' that I pushed through the GPO.  but does not do the SSO.

IE 64 bit sees the 'automatic logon with current user & password' and pushes SSO to our sharepoint site.

Missing something ... ?
Anything in your event logs when this happens? Especially the security section. Has this ever work with 32 bit?
All workstations are affected? Had SSO ever worked with these workstations? and one more - do you have any other applications other than SharePoint that have SSO working (PeopleSoft for example) ?
synertiaAuthor Commented:
event error:
Log Name:      Security
Source:        Microsoft-Windows-Security-Auditing
Date:          6/18/2013 10:01:41 AM
Event ID:      4957
Task Category: MPSSVC Rule-Level Policy Change
Level:         Information
Keywords:      Audit Failure
User:          N/A
Computer:      ALXWK63.gbhawk.weblynx.net
Windows Firewall did not apply the following rule:
Rule Information:
 Name: Core Networking - IPHTTPS (TCP-In)
Error Information:
 Reason: Local Port resolved to an empty set.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-Security-Auditing" Guid="{54849625-5478-4994-A5BA-3E3B0328C30D}" />
    <TimeCreated SystemTime="2013-06-18T14:01:41.260474200Z" />
    <Correlation />
    <Execution ProcessID="504" ThreadID="556" />
    <Security />
    <Data Name="RuleId">CoreNet-IPHTTPS-In</Data>
    <Data Name="RuleName">Core Networking - IPHTTPS (TCP-In)</Data>
    <Data Name="RuleAttr">Local Port</Data>
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now