• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 453
  • Last Modified:

Runtime error when uploading a project

Dear Experts,

I'm having a problem when I upload unedited downloaded projects.
We're talking about Blogengine 2.8 and Umbraco CMS 6.

This is the standard error:

Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a tag within a "web.config" configuration file located in the root directory of the current web application. This tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration> <system.web> <customErrors mode="Off"/> 
     </system.web> </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration> <system.web> <customErrors mode="RemoteOnly"  
    defaultRedirect="mycustompage.htm"/> </system.web> </configuration>

Open in new window

Regarding BlogEngine 2.8, IIS 7.5 says:

64:   </system.serviceModel>
65:   <system.web.extensions>
66:     <scripting>

Open in new window

...and regarding Umbraco 6:

164:   <!-- ASPNETAJAX -->
165:   <system.web.extensions>
166:     <scripting>

Open in new window


So in both cases, the error is in the web.config file, and it is called "HTTP-error 500.19 - Internal Server Error". The error code is 0x80070032.
I can also say that it is the same online host, just another domain and hotel. It amazes me that I upload an unedited downloaded project that is successful build on my own computer (through VWD), but when it is uploaded - it's another story!
What's wrong, and how can i fix it?

Thanks in advance!
DanishCoder
0
DanishCoder
Asked:
DanishCoder
1 Solution
 
Roopesh ReddyIT AnalystCommented:
Hi,

With the information provided, we can't resolve the issue. Enable Custom Errors display by adding the following code in web.config file.

<configuration> <system.web> <customErrors mode="Off"/> 
     </system.web> </configuration>

Open in new window


Moreover, try setting the ASP.NET framework version to 4.0!!!

Hope it helps u...
0
 
DanishCoderAuthor Commented:
Hi Roopeshreddy,

Thanks for your reply.

In the meantime I've contacted my host, and they told me that I had to give them permission to move that specific domain to a Windows2008 server, as it wasn't default. I think that's the reason for the errors I described!

/DC
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now