Solved

NFS in Unix

Posted on 2013-06-05
5
431 Views
Last Modified: 2013-06-24
I created a NFS Share on one linux server.

[root@desktop4 ~]# cat /etc/exports
/prod  *(rw,sync)


[root@desktop4 ~]# showmount -e localhost
Export list for localhost:
/prod *


Mounted on 2nd Linux server

[root@desktop10 ~]# ls -ld /prod/apache/
drwx------. 2 root root 4096 Jun  5 18:30 /prod/apache/

[root@desktop10 ~]# mount -t nfs 10.10.10.39:/prod /prod/apache/
[root@desktop10 ~]# ls -ld /proc/apac

drwxr-xr-x. 2 nobody nobody 4096 Jun  5 13:13 /prod/apache/
[root@desktop10 ~]#



I did shared with rw permission on the NFS server, how it is mounting with following permission.

drwxr-xr-x. 2 nobody nobody 4096 Jun  5 13:13 /prod/apache/


Can some one explain how permission works here.  I am kind of new to NFS.
0
Comment
Question by:ittechlab
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 78

Assisted Solution

by:arnold
arnold earned 250 total points
ID: 39224529
Usually, if you do not specifically grant root with read write rights in exports, root will be mapped to a nobody dealing with accessing the NFS resource.
http://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-nfs-server-config-exports.html
0
 

Author Comment

by:ittechlab
ID: 39225463
I tried to mount a nfs share and i am getting this error. please advice

root@host2:/root> mount -F nfs host1:/tmp/test /test
nfs mount: mount: /test: Not owner

I did share on Linux system and mounting on Solaris Unix.
0
 

Author Comment

by:ittechlab
ID: 39225514
when i share a nfs mount on linux, isn't that nfs ver=4 by default?

Red Hat Enterprise Linux Server release 5.9 (Tikanga)
0
 
LVL 78

Expert Comment

by:arnold
ID: 39225805
Post the exports file.
ls -la / |grep test
You can use an option to explicitly specify the nfs verizon to use, 5 might default to NFS version 3.
0
 
LVL 13

Accepted Solution

by:
Sandy earned 250 total points
ID: 39235809
try by using username and password while mounting.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

697 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question