Terminal Services User Profile

Hi All,
Please advise on the followings:

Windows Server 2003 Terminal server.

I would like to hide some unwanted program and icon for Terminal service users on RD session.
Any idea?

Who is Participating?
tsnironeConnect With a Mentor Commented:
I usually move the shortcuts (rather than just deleting them) from

c:\documents and settings\All Users\Desktop


c:\documents and settings\Administrator\Desktop


c:\documents and settings\All Users\Start-Up


c:\documents and settings\Administrator\Start-Up

That way I can find my way back to the shortcuts if I ever need to.
To hide the icons I simply browsed (as Administrator) to:

c:\documents and settings\USERNAME\Desktop


c:\documents and settings\USERNAME\Start-menu

and deleted the programs/icons you want to hide from the USERNAME

To ensure that the USERNAME is not allowed to run the program at all I believe you will have to go to the exe file properties and edit the security-tab.

Hope this helps! :)
mikenusAuthor Commented:
Thank you for your post.  But TS user profile are stored in D Drive. administrator got no access right.
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

you'll need to get administrator permissions on those user profile folders if you want to accomplish your goal. typically, at least domain admins should have administrator access to the entire computer.
mikenusAuthor Commented:
I have access to their folder , but under their Desktop folder, I can not see any icon or short cut.

Another thing is Is it possible to change TS User roaming profile to Mendatory Profile ?

if you're looking for universal icons and desktops (example, the adobe reader icon), you'd have to remove them from the c:\users\public\public desktop folder (public desktop is a hidden folder). the users who you do want to have access to some of those shortcuts, you'd have to manually place on their individual desktop folders.

the public folder is similar to the default user folder in windows xp/2003.
mikenus: Have you tried to edit the "Desktop" folder under the "user" called "All users" ?
oops sorry, yes ... i forgot you mentioned it's a 2003 server. above user is correct. the 2003 location for all the users is c:\documents and settings\all users\desktop
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.