Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 315
  • Last Modified:

Exchange 2003 Outbound Queueing

I have a mail server run on Exchange 2003 Service Pack 2, on a Microsoft Server 2003 32bit.  I am having a issue when some messages are getting stuck in the outbound queue.  This issue is very intermittent, and only happens to messages that are leaving the organization.  The organization is email security solution provided my McAfee Saas to secure incoming filter out spam, and check all emails that are going outbound and encrypt any emails that are going outbound.  

There is a SMTP Connector setup to McAfee Saas to forward all emails through their system and send it out our behalf.

When I check the queues, I seem some messages stuck in a retry.  When I look up the message in Message tracking center, it looks like the system never tried to trigger the final hop.  I have contacted McAfee and they are not seeing any history of the messages coming to their end.  It look like the message never leaves the system.

I attached a sample screenshot of to emails that were tracked one was successfully sent and the other was not.  Both emails were sent by the same user and sent to the same recipient.

The issue is intermittent not all messages are getting stuck only some, and appears to be be random.
Successful-Suck-Email.pdf
0
hinduguy
Asked:
hinduguy
  • 4
  • 3
1 Solution
 
Simon Butler (Sembee)ConsultantCommented:
I would start by recreating the Connector. Ensure that you don't have a smart host on the SMTP Virtual Server as that can cause problems.

Finally, if you have file level AV software on the server, make sure it has the correct exclusions for Exchange. If it is McAfee, ensure their SMTP scanning feature is disabled.

Simon.
0
 
hinduguyAuthor Commented:
I have updated Trend Micro to exclude the Exchange from the file level scanning, and remove the smart host value from the SMTP Virtual server.  I have not recreated the Connector, because I not sure why the connector would need to be re-created?

I have removed the queued messages with NDR and not I don't see any messages queuing again.

I am not sure if the issue is really resolved, but why would the messages not get delivered out?  They are just stuck in retry?  It does not seem like they are actually trying to send again.
0
 
hinduguyAuthor Commented:
I am getting some emails stuck in the queue now and they are all going to external users and number or recipients on the email message and there is a warning in the event log from the exchange server:

 Event Type:      Warning
Event Source:      MSExchangeTransport
Event Category:      Connection Manager
Event ID:      4006
Date:            6/10/2013
Time:            2:47:29 PM
User:            N/A
Computer:      Computer
Description:
Message delivery to the host 'IP ADDRESS' failed while delivering to the remote domain  'DNS' for the following reason: Unable to open the message for delivery.


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: e0 02 04 c0               à..À
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Simon Butler (Sembee)ConsultantCommented:
That usually means AV is still scanning something it shouldn't be.

Simon.
0
 
hinduguyAuthor Commented:
Ok I will remove the agent from server for a day.
0
 
hinduguyAuthor Commented:
I removed the AV Agent, and I get the same error message and I unfreeze the message for delivery.
0
 
Simon Butler (Sembee)ConsultantCommented:
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now