Solved

Missing data in ssrs report

Posted on 2013-06-06
4
636 Views
Last Modified: 2013-06-07
I have an SSRS report that has an error when called from within a C# application, but the error is not present when displayed within BIDS. Two screenshots attached. The error is that there is missing data in the 3rd row. The first and 2nd last columns in the third row appear correctly in both, but there is missing data in between. This 3rd row is of cumulative data, except for the 39401 and 200525 which are literals.

Good:

Error:


using System;
public partial class Admin_SYSReport : System.Web.UI.Page
{
    private String sysNumber="000000000";
    protected void Page_Load(object sender, EventArgs e)
    {
        if (!IsPostBack)
        {
            sysNumber = Request.QueryString[("sysNumber")];
            PrepareReport();
        }
    }
    private void PrepareReport()
    {
        SYSCoverSheetReportViewer.Reset();
        SYSCoverSheetReportViewer.ShowToolBar = true;
        SYSCoverSheetReportViewer.ProcessingMode = Microsoft.Reporting.WebForms.ProcessingMode.Remote;
        SYSCoverSheetReportViewer.ServerReport.ReportServerCredentials = new Transactions.Admin.ReportServerNetworkCredentials();
        SYSCoverSheetReportViewer.ServerReport.ReportServerUrl = new Uri("http://---------/ReportServer");
        SYSCoverSheetReportViewer.ServerReport.ReportPath = "/SYSCoverSheet/SYSCoverSheet";

        FillParameters(SYSCoverSheetReportViewer.ServerReport);
        SYSCoverSheetReportViewer.ServerReport.Refresh();
    }
    private void FillParameters(Microsoft.Reporting.WebForms.ServerReport report)
    {
        var rpArray = new System.Collections.Generic.List<Microsoft.Reporting.WebForms.ReportParameter>();
        rpArray.Add (new Microsoft.Reporting.WebForms.ReportParameter("SYSNumber", sysNumber));
        rpArray.Add(new Microsoft.Reporting.WebForms.ReportParameter("LongDescription", "This is a long description"));
        report.SetParameters(rpArray);
    }
 }
0
Comment
Question by:allelopath
  • 2
  • 2
4 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 39228870
If you make the column wider does the data display?

mlmcc
0
 
LVL 1

Author Comment

by:allelopath
ID: 39229002
That's good thinking, but I had already tried that and it is not the problem.
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 500 total points
ID: 39229023
I don't use SSRS but have seen similar things in WebI and Crystal.

mlmcc
0
 
LVL 1

Author Comment

by:allelopath
ID: 39229720
Figured it out, sort of. Some sort of rdl.data cache problem.
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
linq, c# 8 33
Visual Studio hangs on running project 6 61
Unlocking a column in excel using C# 17 27
How to force output to ascii 2 38
How to use Variables  and Custom code in SSRS report and Assembly reference to use compile shared code in SSRS. Its big question for all who are working with SSRS. It is easy to create assembly and refer in SSRS report, still there are some steps…
Occasionally there is a need to clean table columns, especially if you have inherited legacy data. There are obviously many ways to accomplish that, including elaborate UPDATE queries with anywhere from one to numerous REPLACE functions (even within…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question