Windows 7 Explorer Viewing Network Drive

I have a Buffalo Link Station Drive on my network we are on the LAN side of a Sonicwall firewall router that issues DHCP 192. addresses.  My Windows 7 workstation as well as the Buffalo drive pick up their respective 192.XXX.XXX.XXX address from the Sonicwall based on their mac addresses.  Everything worked fine at one time.  I was able to used Windows explorer and go to "network" and view the Buffalo drive, save and retrieve files from it.

Some time ago the icon changed when I click on "network" in Windows Explorer.  Now instead of a drive icon I get a Windows Media Player icon and I can only see media type files, music, video, etc.  What happened?  How do I fix it and return it to "normal"?

Thanks!
LinkStation1.jpg
LinkStation2.jpg
EricHomaAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
lauchangkwangConnect With a Mentor Commented:
What if you try to open a folder, then type :

\\192.168.2.197

can you access and see all other files ??
0
 
lauchangkwangCommented:
Have a check under network and sharing center under control panel, make sure the "File Sharing" option is turn on.

File Sharing
0
 
ded9Commented:
Close all apps and then run this fixit


http://support.microsoft.com/mats/windows_file_and_folder_diag


Restart system and check the drive icons.




Ded9
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
EricHomaAuthor Commented:
File sharing is turned on.  I ran the diag from the link provided and then re-started.  Still the same.
0
 
ded9Commented:
You can try this non microsoft utility to restore drive icon

http://www.door2windows.com/how-to-change-drive-icons-in-windows-7/



Ded9
0
 
EricHomaAuthor Commented:
I think that it is more than just an icon change.  Somehow the operating system has associated the drive with Windows Media Player and when you double-click it, it opens Windows Media Player and you can see only media type files that are on the drive.  I tried to right click and look at properties but there are no available menus to make changes there.
0
 
ded9Commented:
Did u try the utility.

Can also try this drive regfix

www.winhelponline.com/fileasso/drive_fix_w7.zip

restart system and check....if nothing works then chances are the user profile might be corrupted....create new user account ..reboot login under the new user account and check.





Ded9
0
 
EricHomaAuthor Commented:
I'm thinking it may have something to do with folders vs. libraries.
0
 
ded9Commented:
Did u try new user account from control panel




Ded9
0
 
lauchangkwangCommented:
Make sure the File sharing is turned on for both PC but not only the current PC that you are using. Possible to print screen under the "Network and Sharing Center" page then upload it here ?
0
 
EricHomaAuthor Commented:
Still no luck trying everything above as well as removing media player from the system.
Untitled---2.jpg
0
 
ded9Commented:
I think its a share issue....it should work in a new user account...try shareenum

http://download.sysinternals.com/files/ShareEnum.zip

Run this file and post screenshot.



Ded9
0
 
EricHomaAuthor Commented:
I ran it and it says that no domains or workgroups were found on my system.
0
 
ded9Commented:
I hope you ran it as admin.... i think there is some connectivity or permission issue.

Did u try lauchangkwang step



Ded9
0
 
EricHomaAuthor Commented:
Ok, I just went to the Start button and left-clicked.  Entered into the "Search for Programs and Files" window the path as shown above, \\192.168.2.197.  It gave me a login window where I was able to enter by username and password for the LinkStation drive.  That worked!  It allowed me to access my files, folders, etc.  I sure wish I new why Windows Explorer stopped working the way it used to.
0
 
ded9Connect With a Mentor Commented:
Try mapping drive via explorer and post screenshot or video

http://windows.microsoft.com/en-in/windows7/create-a-shortcut-to-map-a-network-drive

If you see the above article ..you will see an option called connect using different credentials.
Put a check on that and then try mapping. It will prompt for user name and password. Enter those details and check.




Ded9
0
 
EricHomaAuthor Commented:
I was able to map it using  \\192.168.2.197.  It now shows up in explorer as a network share.
0
 
ded9Commented:
Restart system and check again



Ded9
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.