Solved

Cisco 3850 - Slow Intervlan Routing (1 MB/s) on 1 Gig Interfaces

Posted on 2013-06-07
4
3,384 Views
Last Modified: 2013-06-12
I have a new almost stock installation of a Cisco 3850 doing intervlan routing (I don't even have any security between VLAN's yet).  Any file transfers between VLAN's are very slow (no more than 1 MB/s).  File transfers within a VLAN are fine.  

I am running the latest IOS software for this device.

Any thought on what could be causing this issue?

The config:


Current configuration : 6519 bytes
!
! Last configuration change at 19:12:12 UTC Thu Jun 6 2013 by avccnet
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-SR-3850
!
boot-start-marker
boot system switch all flash:/packages.conf
boot-end-marker
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret 4 <password>
enable password <passsword>
!
username <username> privilege 15 password 0 <password>
no aaa new-model
switch 1 provision ws-c3850-24t
ip routing
!
!
!
qos wireless-default-untrust
!
crypto pki trustpoint TP-self-signed-0
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-0
 revocation-check none
 rsakeypair TP-self-signed-0
!
!
crypto pki certificate chain TP-self-signed-0
 certificate self-signed 01
  <Certificate>
        quit
!
!
!
!
!
diagnostic bootup level minimal
identity policy webauth-global-inactive
 inactivity-timer 3600
spanning-tree mode pvst
spanning-tree extend system-id
!
redundancy
 mode sso
!
!
!
class-map match-any non-client-nrt-class
  match non-client-nrt
!
!
!
!
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 negotiation auto
!
interface GigabitEthernet1/0/1
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/6
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/7
 description Trunk Port
 switchport mode trunk
!
interface GigabitEthernet1/0/8
 description Unused Ports
!
interface GigabitEthernet1/0/9
 description Unused Ports
!
interface GigabitEthernet1/0/10
 description Unused Ports
!
interface GigabitEthernet1/0/11
 description Unused Ports
!
interface GigabitEthernet1/0/12
 description Unused Ports
!
interface GigabitEthernet1/0/13
 description Unused Ports
!
interface GigabitEthernet1/0/14
 description Unused Ports
!
interface GigabitEthernet1/0/15
 description Unused Ports
!
interface GigabitEthernet1/0/16
 description Unused Ports
!
interface GigabitEthernet1/0/17
 description Unused Ports
!
interface GigabitEthernet1/0/18
 description Unused Ports
!
interface GigabitEthernet1/0/19
 description Unused Ports
!
interface GigabitEthernet1/0/20
 description Unused Ports
!
interface GigabitEthernet1/0/21
 description Unused Ports
!
interface GigabitEthernet1/0/22
 description Unused Ports
!
interface GigabitEthernet1/0/23
 description Unused Ports
 !
interface GigabitEthernet1/0/24
 description To Internet Firewall
 no switchport
 ip address 192.168.1.254 255.255.255.0
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan7
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.100.11
 ip helper-address 192.168.100.10
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.100.110
 ip helper-address 192.168.100.111
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address 192.168.100.110
 ip helper-address 192.168.100.111
!
interface Vlan90
 ip address 192.168.90.1 255.255.255.0
!
interface Vlan91
 ip address 192.168.91.1 255.255.255.0
!
interface Vlan100
 ip address 192.168.100.1 255.255.255.0
!
no ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password <password>
 login local
 transport input ssh
line vty 5 15
 password <password>
 login local
 transport input ssh
!
wsma agent exec
 profile httplistener
 profile httpslistener
wsma agent config
 profile httplistener
 profile httpslistener
wsma agent filesys
 profile httplistener
 profile httpslistener
wsma agent notify
 profile httplistener
 profile httpslistener
!
wsma profile listener httplistener
 transport http
!
wsma profile listener httpslistener
 transport https
ap dot11 24ghz rrm channel dca 1
ap dot11 24ghz rrm channel dca 6
ap dot11 24ghz rrm channel dca 11
ap dot11 5ghz rrm channel dca 36
ap dot11 5ghz rrm channel dca 40
ap dot11 5ghz rrm channel dca 44
ap dot11 5ghz rrm channel dca 48
ap dot11 5ghz rrm channel dca 52
ap dot11 5ghz rrm channel dca 56
ap dot11 5ghz rrm channel dca 60
ap dot11 5ghz rrm channel dca 64
ap dot11 5ghz rrm channel dca 149
ap dot11 5ghz rrm channel dca 153
ap dot11 5ghz rrm channel dca 157
ap dot11 5ghz rrm channel dca 161
ap group default-group
end

SW-SR-3850#sh ver (edited)

Switch Ports Model              SW Version        SW Image              Mode
------ ----- -----              ----------        ----------            ----
     1 32    WS-C3850-24T       03.02.01.SE       cat3k_caa-universalk9 INSTALL


Configuration register is 0x102

SW-SR-3850#
0
Comment
Question by:imalc3142
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 18

Expert Comment

by:Akinsd
ID: 39229073
Turn on IP CEF
0
 
LVL 1

Author Comment

by:imalc3142
ID: 39229668
Thanks for your reply.

IP CEF is enabled on all interfaces (sample sh cef interface command):

SW-SR-3850#sh cef interface g1/0/1
GigabitEthernet1/0/1 is up (if_number 5)
  Corresponding hwidb fast_if_number 5
  Corresponding hwidb firstsw->if_number 5
  Internet Protocol processing disabled
  Hardware idb is GigabitEthernet1/0/1
  Fast switching type 1, interface type 146
  IP CEF switching enabled
  IP CEF switching turbo vector
  IP Null turbo vector
  IP prefix lookup IPv4 mtrie 8-8-8-8 optimized
  Input fast flags 0x0, Output fast flags 0x0
  ifindex 4(4)
  Slot 1 Slot unit 1 VC -1
  IP MTU 0

Any other suggestions?
0
 
LVL 1

Accepted Solution

by:
imalc3142 earned 0 total points
ID: 39230009
Hi All,

This is a bug in the IOS for the landbase licensing.  

We moved to a evaluation license and a fix should be out next week (hopefully).

Buggy software:

 WS-C3850-24T       03.02.01.SE       cat3k_caa-universalk9

Thanks for all your help
0
 
LVL 1

Author Closing Comment

by:imalc3142
ID: 39240439
Cisco IOS Bug
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
fabric 1 80
Router disappearing from network on one pc 18 49
ip igmp join-group 8 85
Port Forwarding 4 61
This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question