Solved

Uploading Files in Joomla 3.0 through Media Manager will not load

Posted on 2013-06-07
14
903 Views
Last Modified: 2013-07-02
I have a logo that just will not upload through the Media Manager in Joomla 3.1 For some reason the minute I click the Start Upload button the screen goes blank and white. Nothing gets uploaded. I just wondered if something like antivirus would block that or if there is a problem with Joomla 3.1 I do not know about. It is strange as it has worked before now it will not. The only thing that I see that has changed on this machine is the Anti-Virus. I have never known AV to stop an upload when all my FTP stuff works just fine.
0
Comment
Question by:ruavol2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 5
14 Comments
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39230142
It's a long shot, but are you sure you have plenty of room left on the server?

Sometimes I will try to do a backup (akeeba) and it fails.  And it turns out that particular site had reached its server file size limit.

Rowby
0
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39230163
Here's a discussion on the Joomla foum about this issue.  Check out the comments about "flash" issues, for example.   Note: This is about Joomla 1.5...

Joomla forum

Also note the following from mediamanger documentation:

The Media Manager's maximum upload size can be changed to an amount other than 10M in the Global Configuration.
0
 

Author Comment

by:ruavol2
ID: 39230294
I just called the AV carrier. It is not the AV or the firewall
The file is only 52 kb,,,,,and a png file. So it is tiny.
Server has 150 gb available....I think I am covered.
Any thoughts
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39230426
Try this.

Got to mediamanager.  Click on the "Options" icon.  Check the various options.  

One thing to look at is " Enable flash uploader". If it is set to "Yes" change it to "No".  

Rowby
0
 

Author Comment

by:ruavol2
ID: 39231131
I went to the Media Manger Options and There is no Enable Flash Uploader. I did find the following under Media Manager. I looked through the other settings and found nothing. I cannot figure out why I am having trouble setting and saving something and the setting does not save. Please look at image provided. Your thoughts.....?
JoomlaMediaMangerSettings.png
0
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39231766
1)  I assume you are logged in as Administrator or SuperAdministrator?  If not let me know.
2)  On one forum (with an earlier version of Joomla) someone said "To fix the problem, simply go to Components->Media Manager->Options and save them! Don't make any changes, just save them. After you do that.... all is well again and you can upload from Media Manager."

3)  Go to your Joomla > System > Global Configuration and hit the "Save" button.  Are you able to save, or do you get an error message.  (A long shot, but just testing.)

BTW I am now testing your issue on a fresh Joomla! 3.1.1 install.  I am able to switch the Restrict Uploads to NO or YES  and save without problem.  The saves retain my selection.

Rowby
0
 

Author Comment

by:ruavol2
ID: 39234688
When I go to the User Manger and login as the Administrator. It shows me as a Super User.....old version used to say I was a Super Admin. However I cannot delete a registered user. I go to the Media Manager and try to upload. I get the blank white screen. When I try to save the settings same problem.

You made me think about the Super Admins or Super Users as they are called now. The only thing I can think of that is not what I am used to is that I go to my ISP and to my PLESK Parallels Panel and there is a link that takes me to the Joomla Login page. I am not sure that has anything to do with it. I would not think so but I am trained to notice discrepancies.

Can you think of any other place I can look......this is baffling.....?
0
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39234872
I don't think accessing through PLESK will solve the issue.

Not sure what to do next.  However it seems like a permission issue.

I just did a save in config in the media manger options.  I'm downloading the site and will try to see what file in joomla was "saved" at this time (June 10, etc.)  to see what file(s) might be having a permission issue on your site.

It'll take a while to download all the files (i'm doing it via ftp, not akeeba) so let's see if my download gives me a clue.

Rowby
0
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39235007
Well I only see a few files changed from the ftp download.

Check this one:  /logs/jcontroller.log.php

The file permissions on that file are (in my case):  644

Do you know how to ftp and view file permissions?  I use filezilla as my ftp client.  Makes it easy.

Rowby
0
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39235013
Also the file permissions folder itself has this permission:  755
0
 
LVL 9

Assisted Solution

by:Rowby Goren
Rowby Goren earned 500 total points
ID: 39235188
If no easy solution is found, you do know there are other ways, within joomla, to upload files.

Such as:

http://extensions.joomla.org/extensions/core-enhancements/file-management

For example, I've used eXtplorer since Joomla 1.x

Rowby
0
 
LVL 9

Accepted Solution

by:
Rowby Goren earned 500 total points
ID: 39236545
I'll stay out of your new EE question.  Let's see what other Joomla experts suggest.  

I'll take a look at it now and then....

But *do* ftp to your configuration.php file in your site's root.  What are the permissions?  

If you don't ftp, you can probably view the permissions of that file via your Plesk control panel's file manager.  (I don't use plesk, I use Cpanel, but I am sure Plesk has a similar file manager.)

 If it's something like 444 then they are "Read Only" and cannot be modified -- without changing permissions something like 644.  

If that doesn't work, there could be an "owner" issue.  Occasionally I've used a host that screwed up the owner of joomla files .  But as I recall the host can easily fix that.  So if you don't get an acceptable answer to your other EE question, check with your host regarding who "owns" the files.  Not only the configuration.php file but the rest of the files in your joomla installation.

This article might be helpful to your hosting support person
http://forum.joomla.org/viewtopic.php?f=9&p=2904853&sid=77191eace652af75d960c6db82bcb9a2#p2904350

Yet another possible solution. You shouldn't have to go this far, but here is a thread at akeeba backup's site, using their Admin Tools component.
https://www.akeebabackup.com/documentation/admin-tools/fixing-permissions.html
Rowby
0
 

Author Comment

by:ruavol2
ID: 39249575
Here is what we found in Joomla it showed there were two super users.

When I go into PHPMyadmin database there is a missing field in the Joomla table. Jos_Users table is missing the UserType field and the GID field. I placed new fields in the table and no luck. Same problem. I am open to sending you logins and to take this offline. I am willing to pay for this solutions. Currently I have the Parallels Plesk Team in Russia working on this to verify it is not a PLESK problem. If it is not let me know if you are interested in looking further. I am completely locked out of the website development. I have people very upset with me and people waiting to purchase product. Let me know what you think.
ruavol2
0
 

Author Closing Comment

by:ruavol2
ID: 39295288
The problem lied within PLESK we think. I am not sure this will warrant putting it in the knowledge base. Thank you for your help.
0

Featured Post

Get Actionable Data from Your Monitoring Solution

Your communication platform is only as good as the relevance of the information you send. Ensure your alerts get to the right people every time with actionable responses. Create escalation rules that ensure everyone follows the process and nothing is left to chance.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Although a lot of people devote their energy toward marketing for specific industries, there are some basic principles that can be applied to any sector imaginable. We’ll look at four steps to take and examine how those steps were put into action fo…
Australian government abolished Visa 457 earlier this April and this article describes how this decision might affect Australian IT scene and IT experts.
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question