Solved

Router setup question CCNA

Posted on 2013-06-07
8
434 Views
Last Modified: 2013-06-08
I'm trying to see how ip route works with static route entry. I set up a simple 3 router setup and tried to ping. I can ping next router, but pinging from Router 3 to Router 1 fails. I put the static ip route to 10.1.1.0 network, still fails. what am I doing wrong? I used fastethernet interfaces to connect routers and used crossover cable.

here are the configs of the 3 routers and the layout image is attached.

Router 1
Router#sh run
Building configuration...

Current configuration : 460 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router

!
interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end



===========================
Router 2

Router#sh run
Building configuration...

Current configuration : 470 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
interface FastEthernet0/0
 ip address 10.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

======================================
Router3

Router#sh run
Building configuration...

Current configuration : 502 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router

!
interface FastEthernet0/0
 ip address 10.1.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.1.1.0 255.255.255.0 10.1.2.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end
r1.jpg
0
Comment
Question by:crcsupport
  • 4
  • 4
8 Comments
 
LVL 24

Assisted Solution

by:smckeown777
smckeown777 earned 500 total points
ID: 39230305
On Router1 you don't have a route to Router3...


ip route 10.1.2.0 255.255.255.0 10.1.1.2

Add that to Router1 to fix...
0
 
LVL 1

Author Comment

by:crcsupport
ID: 39230337
I didn't add the route because I was testing to ping from router 3 to router 1.
I added the route, but it doesn't resolve the problem any. I rather think something other than ip routes...
0
 
LVL 1

Author Comment

by:crcsupport
ID: 39230342
just to let you know, I'm testing this using Cisco Packet Tracer.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 24

Assisted Solution

by:smckeown777
smckeown777 earned 500 total points
ID: 39230374
Not sure what you mean by 'I didn't add the route because I was testing to ping from router 3 to router 1' - in order for traffic to flow between 1 and 3 you need static routes...regardless of what testing you are doing...

So you've both route commands now on R1 and R3 yes?
What does

sh ip route

command produce when run on R1 and R3?
0
 
LVL 1

Author Comment

by:crcsupport
ID: 39230400
You're right. I added again now it solves the problem. I don't know why it didn't work before, maybe I added wrong. If I add the wrong static ip route, does router removes the incorrect route automatically because I don't see the route I added to Router 1 anymore after you told me.
0
 
LVL 24

Assisted Solution

by:smckeown777
smckeown777 earned 500 total points
ID: 39230409
Not that I know of, you can add multiple routes...only way to remove them is to issue the

no ip route 10.1.1.0 255.255.255.0 10.1.2.1

command - i.e. the no being the key command above
0
 
LVL 1

Author Comment

by:crcsupport
ID: 39230443
Thanks the problem resolved.
If a router is supposed to have ip route on table  for all remote network, then now I think it seems somewhat weird. For stub router (like gateway from lan to internet) is ok. I can configure default route (ip route 0.0.0.0 0.0.0.0 s0/0/0). But how about the router in tier 1,2,3 routers outside. Do they actually keep all internet network route ??? I'm confused cause' I just saw for both router to communicate, they both need to have routes configured for each other
0
 
LVL 24

Accepted Solution

by:
smckeown777 earned 500 total points
ID: 39230453
Routers in the real world(i.e. not stub routers) all use dynamic routing protocols...not static like you are using to test...

I.e. they use OSPF/EIGRP/RIP/etc...etc...
They will have routes to routers within their 'network' - no router has routes to every router on the planet...but with dynamic routes they can get to the final destination since the next router in the loop will have slightly different/more routes to other destinations etc...etc...so its all dynamic

For testing with static routing you always need routes on both ends to make it work
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
policy routing to fw2 18 68
clear arp 1 29
Unable to reach an IP located on a Dell switch from an HP switch 18 55
Non Distrubtive Core Switch Repacement 8 24
AWS has developed and created its highly available global infrastructure allowing users to deploy and manage their estates all across the world through the use of the following geographical components   RegionsAvailability ZonesEdge Locations  Wh…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question