?
Solved

Both Tabs & Variation Images suddenly don't work in woocommerce site

Posted on 2013-06-07
9
Medium Priority
?
587 Views
Last Modified: 2013-07-02
Hi,

I have been working on this ecommerce site and I suddenly realized at some point that to things that were working before are no longer working.

1. The woocommerce tabs are now displaying all tab content right up front.
2. selecting a product variation from the dropdown does no longer switch the main image to the new selected variation's image.

This feels like a javascript issue but i can't figure it out after hours of digging around.

I have tried turning off ALL plugins except woocommerce itself and it did not solve this. woocom is updated to the last version.

See this page for the issues

What can be causing this?

Thanks in advance
0
Comment
Question by:James-Wise
  • 3
  • 3
  • 3
9 Comments
 
LVL 61

Expert Comment

by:Julian Hansen
ID: 39231208
Looks like the script that is used to initialise the tabs is not present.

What were you using to implement the tabs - and where were you invoking it?

I cannot find anything in the source that refers to either tabs or woocommerce-tabs which tells me you are not running any JScript to turn those elements into active tabs - and also explains why all the content is not showing.

There are not JS errors showing on the page either so not a fault in a running script.

Do you have a version of the site that was working still available to compare against?

Other than that look on the page where you are putting the tabs and make sure the JScript hat initialises them is being implemented.
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 39231731
The page is no where near being valid HTML5.  The HTML validator reports 27 errors, including duplicate ids, obsolete attributes, and structural anomalies. The browser will make a best guess about what the code means, but you are never going to have reliable cross-browser performance with a page that is that defective.


Cd&
0
 

Author Comment

by:James-Wise
ID: 39231909
julianH,

The tabs are a built in function of the woocommerce plugin and come with it. I cannot think of touching anything that would have messed with that (although logic says I probably did somehow)

I have regular backups done but not sure I can guess which one was before the issue.

COBOLdinosaur,

27 errors are nice and all but none of them actually points to causing this specific issue (nor do I remember the last site i saw with perfect validation). But this is a dev site being built for layout and functionality first, I haven't even gotten to cross browser compatibility yet or addressing validation errors. (also many issues seemed to have arrived with this template)
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 39231949
nor do I remember the last site i saw with perfect validation

Then you travel in the internet slums.  

Validation should be the first thing in resolving problems.
A ten year old kid can get a template to work, that does not make them a web developer and it is not likely they will build successful sites.


Cd&
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 39231960
BTW if you want to see clean pages feel free to visit my site.  Other than the occassion ampersand not converted to entity in news feeds you won't find a lot that is not valid.

Cd&
0
 
LVL 61

Expert Comment

by:Julian Hansen
ID: 39231998
I agree with CD& on this - clean code is an essential step to resolving issues.

Having said that it is plain that the javascript that is supposed to turn the <li> tabs into active tabs is not firing and no JS errors are being displayed so it stands to reason that something was changed to either

a) Remove the code that turns the html code into a tabbed display
OR
b) The code is there but is not being linked (an ID / class was changed removed

Can you remember when it last worked?
0
 

Accepted Solution

by:
James-Wise earned 0 total points
ID: 39242618
Sorry, I didn't mean to dismiss the validation suggestions. my workflow is a bit different (or backwards perhaps)

In any case, I have solved it.

If anyone is curious, theme was calling an outdated jquery version which was redundant anyway. removed it and that fixed it.

Thanks again for the help!
0
 
LVL 61

Expert Comment

by:Julian Hansen
ID: 39283561
So nothing posted in this question helped you in the slightest?
0
 

Author Closing Comment

by:James-Wise
ID: 39292585
The other suggestions were good but did not solve the issue. I eventually figured out what had caused it and posted for future reference. I am still tremendously grateful for the help
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article is intended for those who are new to PHP error handling (https://www.experts-exchange.com/articles/11769/And-by-the-way-I-am-New-to-PHP.html).  It addresses one of the most common problems that plague beginning PHP develop…
3 proven steps to speed up Magento powered sites. The article focus is on optimizing time to first byte (TTFB), full page caching and configuring server for optimal performance.
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will learn the basics of jQuery including how to code hide show and toggles. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery…
Suggested Courses

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question