Link to home
Start Free TrialLog in
Avatar of ops ahaa
ops ahaa

asked on

Windows SBS server 2003 Rebooting Issue

Q: My Windows 2003 SBS Server is automatically rebooting after Moving FSMO roles to New Physical Server Windows 2008 R2.  Is there a way that i stop this auto reboot on my old server. Because i want to format the old server only after taking complete server backup.

 Q: Whats the Difference between moving FSMO from old server to new server  and Seizing FSMO. I have just move FSMO roles but i didn't seized it. Please explain, thanks.
Avatar of arnold
arnold
Flag of United States of America image

SBS must have/BE the master of all AD related roles.

Spa seizure of roles is only doe when the system with master roles is no longer accessible, HW failure, OS corruption, etc.
Seizing roles means the other system, from which the roles were seized, MUST NEVER BE connected to the network without OS reinstall.
Seizing roles means the original system's configuration will still reflect that it has the roles and the two system will be engaged in contention each claiming it has the role.
ASKER CERTIFIED SOLUTION
Avatar of Sandesh Dubey
Sandesh Dubey
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ops ahaa
ops ahaa

ASKER

Extend 21 day limit

You may find yourself in a position where 21 days isn't enough to finish the migration, if you find yourself in this situation there are two methods for extending this limit.


After the 28 day period (21 plus the 7 above) - Disable Shutdown
This method will prevent the source SBS 2003 server from shutting down indefinitely. From the SBS 2003 server transfer the FSMO roles back to the SBS 2011 server.
From the SBS 2003 server, download and run Process explorer:

http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

Find and right click sbscrexe.exe and choose suspend.
Open regedit and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SBCore.
Right click on SBCore and select permission, add the administrator account and give full control to this key and subkeys, click yes if warned.
In the right hand pane, change the "start" DWORD to 4 (from 2 default).
Now browse to C:\Windows\System32 and locate sbscrexe.exe. Right click, properties, security -> Add everyone and select deny for all.
Go back to Process explorer and select kill process, open task manager and confirm sbscrexe.exe doesn't restart.


FYI to all – DO NOT set the “Start” value to 0 (zero). I did after trying to remember this from memory, it caused a continuous boot loop – zero is a boot time service. I had to boot up with a recovery disk, load up mass storage drivers, load the system registry hive and modify the value to 4. PAIN IN THE @SS!!!
Server Rebooting issue got resolved afer following above mention procedure