[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1548
  • Last Modified:

IIS on Microsoft Surface Pro

I have enabled IIS on my Microsoft Surface Pro running Windows 8. When I start cmd and try "ping localhost" it seems to be working:

C:\windows\system32>ping localhost

Pinging Surface_pro [::1] with 32 bytes of data:
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms

Ping statistics for ::1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

But when I type localhost in Internet Explorer I get "The webpage cannot be found".

How do I fix this?
0
Igor50
Asked:
Igor50
  • 4
  • 2
1 Solution
 
peter197911Commented:
try browsing to 127.0.0.1 (which is the ip address for local host).
It seems you have IPV6 enabled

I think browsing to http://127.0.0.1  should do the job.
0
 
Dave BaldwinFixer of ProblemsCommented:
Ping is the ICMP service which is entirely different from HTTP service used to access web sites.  Usually 'localhost' is defined in your 'hosts' file.  And like @peter197911 points out, it can be IPV4 or IPV6.  But IIS also has a place where you tell it what IP addresses to recognize.  The two places have to agree for 'localhost' to take you to IIS in Internet Explorer.
0
 
Igor50Author Commented:
Browsing to 127.0.0.1 makes no difference.

I read elsewhere that you have to go to Control Panel/Programs and Features/Turn Windows features on or off. And there enable "the options you need". Ok... which ones are they? There are really many options.
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
peter197911Commented:
uhm, as Dave tells. You are mixing things up.

Are you 100% sure you did enable IIS?
The ping command makes no sense indeed.

Go to "√Ądministrative Tools"  and look sfor IIS admin.
See if you can find out something there.
0
 
Igor50Author Commented:
I went to Administrative Tools and enabled more options (I really don't know what they all mean). However, It solved the problem. It works now.

Thanks.
0
 
Igor50Author Commented:
I went to Administrative Tools and enabled more options (I really don't know what they all mean). However, It solved the problem. It works now.
0
 
Igor50Author Commented:
It got me in the right direction.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now