Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 616
  • Last Modified:

How to enable Ubuntu Networking

I installed VMware on Windows 7 and got Ubuntu 3.5.0-23-generic (64-bit) running. Brought up Firefox, but was unable to get to the internet. In xterm, tried to ping 192.168.1.1 (my router) with no luck. (I can do that in my Windows and Cygwin consoles.)

Looking around EE for clues and I found some information that may be helpful.
I have Norton 360 installed.
VM setting for Ubuntu Network Adapter was set to NAT. I changed it to Bridged (not sure of what this does).
In xterm, I ran:
sudo iptables -F
sudo iptables -L

I rebooted my router since another person's problem was solved that way - something about DHCP. Not sure why rebooting router fixed the Ubuntu DHCP problem.
0
phoffric
Asked:
phoffric
  • 8
  • 6
4 Solutions
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
see here, which states the differences between NAT, Bridged and Host Only

http://vmfaq.com/entry/34/

It would seem maybe, that DHCP had stalled on your Router, and was not issuing DHCP Addresses to computers and devices on your LAN.

if you need to install packages on Ubuntu, you type

sudo apt-get install [package name 1]

make sure you have a connection to the internet.

also see here

http://www.howtogeek.com/63997/how-to-install-programs-in-ubuntu-in-the-command-line/
0
 
phoffricAuthor Commented:
@hanccocka
For some reason, I didn't get an email that you posted a comment.

>> make sure you have a connection to the internet.
Can't even ping the router, so unable to get to the internet. If I could get to the internet, then I probably could get the Boost library.
"tried to ping 192.168.1.1 (my router) with no luck. (I can do that in my Windows and Cygwin consoles.)"


>> It would seem maybe, that DHCP had stalled on your Router, and was not issuing DHCP Addresses to computers and devices on your LAN.
Somehow I can ping in the Cygwin console. Assuming that you are right about DHCP, do you know how to fix this problem?

Thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Cygwin console is from the Host.

Clearly networking is not working in the VM.

What is the networking set to for the VM?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
phoffricAuthor Commented:
Not sure if this is what you want to know. In the OP, I said "VM setting for Ubuntu Network Adapter was set to NAT. I changed it to Bridged". I did this based on online search. I'll be at the laptop in about 4 hours. I'll be working now with another person's router/network, so I may not be able to modify the router. But, I'll be home the following weekend. Thanks.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
in bridged mode, the network interface must have an IP Address on the same subnetwork as the host and router for you to be able to get internet access.
0
 
phoffricAuthor Commented:
I was just trying things from previous search when I went to bridge mode. Now I stumble upon something saying that bridged mode is more advanced. I am not familiar with network configuration, so if you can give me the steps (with actual commands) to get this to work, in any way you find easiest, that would be great.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
do you have it set to bridged mode?

do you have a DHCP server on your network which issues IP Addresses?

if no, you will need to configure a static IP Address?

In My first post, I posted a link which explains the different VM network functions, bridged, host and NAT.
0
 
phoffricAuthor Commented:
>> do you have it set to bridged mode?
VMware setting is now bridged mode; I changed it from NAT mode.

>> do you have a DHCP server on your network which issues IP Addresses?
I think I need to get into the router to find that out. I'll see if the landlady even knows the account login to her FIOS router. (She is using WEP for wifi, so I'll try to convince her to improve on that and while we're changing it, I'll see if it is setup as a DHCP server.)

I did notice that the subnet on my DOS window was the usual 255.255.255.0; but on Ubuntu, it was 255.0.0.0. But I have to figure out how to change that subnet. I got so far as thinking that I needed to work with VMware tools (I thought they were installed, but some commands I found online did not work - something like "... route add ...". This weekend, I'll try to figure out how to install VMware tools.

When you referred to a static IP address, were you talking about the Windows 7 laptop or just giving Ubuntu a static address?

As I go to/from my home to my apartment, I don't mind having to modify settings as long as I understand the procedures. Of course, if there's a way to plug and play, that would be nice. I believe that my home router must be a DHCP server since I see actual PC names when I log into it.

Thanks.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
If you connect a PC to your LAN with the router, does it get an IP address, does Internet work automatically?
0
 
phoffricAuthor Commented:
At both home and in the apartment (where I will be this weekend), the PC gets Internet access automatically.

As for installing VMware tools, I have a link that I was looking at; but also found this link from your provided link in your first post:
    http://vmfaq.com/entry/58/

Between the two, I should be able to get it installed, and maybe do that "... route add ..." command.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Okay, so it's possible that your have a function called a DHCP server, which issues IP Addresses automatically to PC on your LAN.

When in bridged mode, does your VM, get an IP Address?

at the console of the VM type ifconfig
0
 
phoffricAuthor Commented:
Problem solved!
In order to do an ifconfig, I decided to find a term with scrollbar. I learned how to do a search using the dashboard.

The ifconfig showed no IP address and only a subnet of 255.0.0.0 as mentioned above.

I noticed some dashboard icons; one was triangular shaped with vertex at bottom and an arc at the triangle's base. It's menu included "Enable Networking", which I selected. ifconfig still did not show an IP address. In same menu I then selected "Auto Ethernet" (even though I was using wifi). ifconfig then showed an inet address and a good Mask.

I was then able to ping the router, yahoo, and bring up Firefox and google.

The title of this question should be "How to enable Unbutu Networking". I'll see if I can get it changed.
0
 
phoffricAuthor Commented:
If I wasn't so rushed, I would have preferred not finding those icons so that I could learn more about Linux networking commands. Another time, maybe.
0
 
phoffricAuthor Commented:
Thanks for steering me in the right direction.
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now