Solved

MIME type “application/octet-stream” rather than “video/x-flv” or “application/x-shockwave-flash”

Posted on 2013-06-09
12
1,723 Views
Last Modified: 2013-06-12
We are having a problem with our web servers delivering all our flash video files as the MIME type “application/octet-stream” rather than “video/x-flv” or “application/x-shockwave-flash”.

I have checked the settings in IIS for all websites. As far as I know it is set up correctly (well at least to my knowledge), but Chrome, Firefox and IE still report the file type as “application/octet-stream”.

Can someone tell me how to change the MIME type for FLV and SWF files?
0
Comment
Question by:MattyS82
  • 6
  • 5
12 Comments
 
LVL 29

Expert Comment

by:Randy Downs
ID: 39233079
Maybe this will help


Please be aware that these steps do not resolve any issue with Flash, but are a configuration step for Microsoft Windows 2003 and Microsoft IIS Server 6.0. Any difficulties in executing these instructions or any errors that may arise from modifying your system settings should be addressed to Microsoft. For more details, please refer to your IIS documentation.

http://helpx.adobe.com/flash/kb/flv-files-dont-stream-windows.html

On the Windows 2003 server, open the Internet Information Services Manager.
Expand the Local Computer Server.
Right-click the local computer server and select Properties.
Select the MIME Types tab.
Click New and enter the following information:
Associated Extension box: .FLV
MIME Type box:flv-application/octet-stream
Click OK.
Restart the World Wide Web Publishing service.
0
 
LVL 1

Author Comment

by:MattyS82
ID: 39233080
Thanks will test that out and get back to you
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39233081
Are you using plesk? If so you need to add mime type under the virtual directories area using mime type tab.

What does your embed code look like?  Flv files are accessed through a player or swf file.
0
 
LVL 1

Author Comment

by:MattyS82
ID: 39240036
Number-1, thanks for the suggestion. After checking the server, this has already been done for FLV files.

Padas, no we are not using plex. Thanks for the suggestion, much appreciated.
0
 
LVL 29

Accepted Solution

by:
Randy Downs earned 500 total points
ID: 39240076
Did these ever work correctly? If so what has changed?

You could try restarting the web site.
0
 
LVL 1

Author Comment

by:MattyS82
ID: 39240080
Number-1. Not within IE they didn't however chrome and firefox works fine.

Perhaps it's the way I have embedded it?
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 29

Expert Comment

by:Randy Downs
ID: 39240084
What versions of IE give you the problem?
0
 
LVL 1

Author Comment

by:MattyS82
ID: 39240089
IE 9 and 10
0
 
LVL 29

Expert Comment

by:Randy Downs
ID: 39240094
If you can send me a test link I'll try with IE8
0
 
LVL 29

Expert Comment

by:Randy Downs
ID: 39240126
Which player is giving the error? Flash Player?

Maybe this will help
http://forums.adobe.com/thread/885448
Flash Player Add-on has been disabled

http://forums.adobe.com/thread/867968?tstart=0
If you have completed the steps in our Enabling Flash Player in Internet Explorer 9 FAQ and continue to have problems seeing Flash content, please see the following video and instructions to learn how to disable ActiveX Filtering.
0
 
LVL 29

Expert Comment

by:Randy Downs
ID: 39240134
This is for Amazon S3 & Wordpress but it might help you:

http://wordpress.org/support/topic/videos-not-playing-in-ie9

IE9 to know what kind of file your video is you have to specify the Content Type because apparently IE9 can't figure it out for itself. In S3, highlight the video file, go to Properties, Metadata. There you will see:

Key: Content Type
Value: application/octet-stream

Change the Value from "application/octet-stream" to "video/mp4", you will have to manually type it there
0
 
LVL 1

Author Closing Comment

by:MattyS82
ID: 39243085
Sometimes it's the most simple thing. Restart of the website fixed the issue
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Hide IE  and Firefox toolbar 5 59
Competitors in URL Dropdown 2 53
Export & Import Bookmarks in FIrefox 1 45
Cannot access secure sites in Internet Explorer 7 48
Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
The goal of the tutorial is to teach the user how to set there setting in Adobe Flash Media Live Encoder and YouTube for optimal video and audio quality.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now