Solved

Server 2003 Repair Install Issue (URGENT)

Posted on 2013-06-09
6
275 Views
Last Modified: 2013-09-05
I have a client I recently acquired that has an SBS 2003 Premium x86 server that is not working properly.  The DNS service will not start, I have tried troubleshooting it and attempted every fix I could find online for: "error 14, no disk storage available".  In addition there are several other issues such as certain services not starting when they are configured to automatically start, the NT backup feature is not functional, the 3rd party imaging software the prior IT guy had installed will not open without the DNS service started etc..  Without NT backup I cannot perform a system state backup.  The server is running Exchange 2003, SQL 2005 databases, and has GP, Active Directory, DHCP, and DNS configurations I would need backed up before I would want to attempt an OS clean install.  I booted off from the media disks which appear to be retail and there is no Repair Install Option available.  I heard that if you boot to the OS disk within the OS and do an upgrade install it will act as a repair install much the same as WIndows 7 upgrade install works with a Windows 7 disk.  Can anyone confirm this to be true or point me in a direction to effectively backup the system state, IE Exchange, Active Directory, Group Policy, DHCP configs, DNS zones and if possible the SQL databases.  Again NT backup will not work and DNS cannot start, I have also troubleshot the NT backup error and event log errors to no avail.  In addition SHadow Protect will not install at the moment because of how damaged some of the services and possibly DLL files are damaged.  I have attempted to re-register all the DLL files, I have ran SFC/ Scannow and re-installed Service Pack 2 files.  Any help would be appreciated.  This is an URGENT matter, thank you in advance.
0
Comment
Question by:Rogue72
6 Comments
 
LVL 14

Expert Comment

by:Don Thomson
ID: 39233448
What disk configuration does the server have?

Have you done a chkdsk  on the system and any data disks- a corrupted disk is what normally causes that error.
0
 

Author Comment

by:Rogue72
ID: 39233473
There are two drive in a RAID 1 configuration.

I have not run a chkdsk as of yet, it may be worth a try.  However, I contacted the prior IT guy and he said he was attempting to repair various things on the server after a virus removal and in the process he ran a hotfix to repair the network connections that were not appearing.  After said hotfix the DNS service began producing the error 14.  I do not know which hotfix he ran, I have tried to find it via google and cannot find anything that the hotfixes do that I found would affect the dns service via the manual repair options.

If I knew which hotfix it was exactly that may help, but he has not been answering via email or phone any longer.

Thank you for your prompt reply.
0
 
LVL 23

Expert Comment

by:Nagendra Pratap Singh
ID: 39233822
You can check the list of updates installed in add/remove programs.
0
Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

 
LVL 30

Expert Comment

by:ded9
ID: 39233863
Uninstall your security software like antivirus ...reboot system ...all services should start working.



Ded9
0
 
LVL 10

Accepted Solution

by:
172pilotSteve earned 500 total points
ID: 39234504
I think you have two choices...  Start over, and manually bring stuff over from the old install, or troubleshoot more thoroughly with what you have..  What you're asking for help with is to backup all the things that aren't working anyway, and I'm afraid you're going to end up restoring yourself right back into the same problem..

That's a LOT of things going on, and it's just a hunch, but I'm betting that there's one big thing that is stopping ALL of your things from working.

First of all,  can you even get into ADUC (Active Directory Users and Computers?)  If so, make sure the computer itself is in the Domain Controllers OU.  There are special permissions attached to that OU (at least by default!), and I've seen where people have "cleaned up" and moved DCs into a structure that they want to manage, and it has messed up EVERYTHING all at once.  

Second, look for expllicit DENY permissions set on the critical directories, like c:\, \windows, etc..  THere shouldn't be any denys, and I have seen someone put a deny on the c:\windows\system32 directory, for example, and it would make the system unusable.  Remember, Deny ALWAYS overrides any explicit grant access.

Disable all the GPOs temporarily.  You dont have to delete them, just unclick the "enabled" checkbox to eliminate them as a culpret.  Remember though, if a GPO changes a registry entry, that registry entry setting will stay set unless something sets it to something else, even if the GPO is unapplied.  For this reason, you should look through the settings on all GPOs.

Download and run ProcMon  (www.sysinternals.com or from the Microsoft website just look for Sysinternals utilities).  This will let you isolate the exact thing that is failing to cause an application to think the disk is full..  Search (and filter) the logs to look for failure events from a process/thread that makes sense for what you're troubleshooting, and see if the ProcMon log doesn't help in some way.

If you really do want to do a "repair", you could try as you describe to do a repair over the existing install, or you could do a "Parallel install" which means to install Windows on the same machine, but into a different directory from the c:\windows that it's in now..  So, when it boots up, you'll get a menu asking which version you want to run..  C:\windows, or C:\NewWin (or whatever you end up calling it)  This way, you can at least start re-creating your users and services on a known clean install, and you'll be able to drag & drop your data files on the same drives.

Personally, I'd keep fighting the problem, but it depends on your comfort level I guess...
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39234686
I repaired a similar install (had a virus, a lot of things were not working anymore after the removal etc) by doing some "upgrade" on the server, with a Windows 2003 R2 CD.
I booted off the CD and chose to upgrade the existing install. Of course, all hotfixes etc. had to be reapplied after that, but this server is now working like a charm and has been so fro more than 2 years now.
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Join & Write a Comment

Suggested Solutions

This article descibes how to create a connection between Excel and SAP and how to move data from Excel to SAP or the other way around.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
The viewer will learn how to simulate a series of coin tosses with the rand() function and learn how to make these “tosses” depend on a predetermined probability. Flipping Coins in Excel: Enter =RAND() into cell A2: Recalculate the random variable…
The viewer will learn how to use the =DISCRINV command to create a discrete random variable, use this command to model a set of probabilities and outcomes in a Monte Carlo simulation, and learn how to find the standard deviation of a set of probabil…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now