Solved

Cisco Routers and IPv6 Networking

Posted on 2013-06-09
4
492 Views
Last Modified: 2013-06-29
Say I have 2 routers, 2901 models with just the fast ethernet interfaces in them.
I am wanting to simulate WAN connections between sites. These sites are just theoretical at this time.

Interface FastEthernet 0/0 on Router 1 is given an IPv6 address of 2001:0:1:1::1/64
Router1(Config-if)# ipv6 address 2001:0:1:1::1/64

Interface FastEthernet 0/0 on Router 2 is given an IPv6 address of 2001:0:1:1::2/64
Router2(Config-if)# ipv6 address 2001:0:1:1::2/64

I have enabled dynamic routing on the interfaces using the following commands:
Router1(Config)# ipv6 router rip company
Router1(Config)# interface fastethernet 0/0
Router1(Config-if)# ipv6 rip company enable
Router1(Config-if)# exit

Router2(Config)# ipv6 router rip company
Router2(Config)# interface fastethernet 0/0
Router2(Config-if)# ipv6 rip company enable
Router2(Config-if)# exit

I have IPv4 addresses assigned to the FastEthernet 0/1 interfaces on both routers

Router1# config t
Router1(Config)# interface fastethernet 0/1
Router1(Config-if)# ip address 10.10.10.1 255.255.255.0
Router1(Config-if)# no shutdown
Router1(Config-if)# end

Router2# config t
Router2(Config)# interface fastethernet 0/1
Router2(Config-if)# ip address 10.10.20.1 255.255.255.0
Router2(Config-if)# no shutdown
Router2(Config-if)# end


On each router, I can ping the WAN interface of the other. I cannot ping the internal IPv4 address from the opposite router. I am looking for a way to allow communication between the two networks. Perhaps a NAT64 entry would work best, or perhaps a static route.

Does anyone have a command I could run on both routers to allow a PC on Router 1's Fast Ethernet 0/1 interface to ping and communicate directly with a PC on Router 2's Fast Ethernet 0/1 interface?

Example config's are welcome, I'll keep trying but I am looking to speed up this process.
0
Comment
Question by:PatrickDoman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 39234156
Here is good exmple config from cisco to work together with IPV4 & IPV6

http://www.cisco.com/en/US/tech/tk872/technologies_configuration_example09186a00800b49a5.shtml

Good luck
0
 
LVL 22

Expert Comment

by:Jody Lemoine
ID: 39234182
IPv6 routing is disabled by default on IOS. Enable it with the command "ipv6 unicast-routing" and things should start working as expected.
0
 

Accepted Solution

by:
PatrickDoman earned 0 total points
ID: 39272524
Here was the fix for the proof of concept. Works great!

Network topology:-    
10.10.10.1 - Router1 - (IPv6) - Router2 - 10.10.20.1


Router1:

interface Tunnel1
ip address 20.20.20.1 255.255.255.0
tunnel source 2001:0:1:1::1
tunnel destination 2001:0:1:1::2
tunnel mode ipv6

ip route 10.10.20.0 255.255.255.0 Tunnel1


Router2:

interface Tunnel1
ip address 20.20.20.2 255.255.255.0
tunnel source 2001:0:1:1::2
tunnel destination 2001:0:1:1::1
tunnel mode ipv6
!
ip route 10.10.10.0 255.255.255.0 Tunnel1
0
 

Author Closing Comment

by:PatrickDoman
ID: 39286404
Cisco TAC engineer helped me through this. Works fine. Was able to ping machines on both sides of the routers.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The conference as a whole was very interesting, although if one has to make a choice between this one and some others, you may want to check out the others.  This conference is aimed mainly at government agencies.  So it addresses the various compli…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
Suggested Courses

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question