[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

exchange 2003 to 2010 migration

Posted on 2013-06-10
17
Medium Priority
?
232 Views
Last Modified: 2013-11-05
I inherited an exchange 2003 setup with an exchange 2010 migration that looks half complete.

I can move mailboxes to the new server but users on the old server are unable to send email outside the domain. . I am not sure what hasn't been completed on the migration.  

I have a test mailbox moved to the 2010 exchange server.  It doesnt' send email  and users that are on the 2003 box can't send email either.  outside the domain that is.  I am sure there is something missing.

AD looks to be in good shape.

Thanks
0
Comment
Question by:lefty431
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 3
17 Comments
 
LVL 44

Expert Comment

by:Amit
ID: 39234753
Create a SMTP Send Connector in 2010 and point it to your Smart Host. Also create one bidirectional RG connector between 2003 and 2010 servers. For this you need to use Powershell. Let me know, if you need steps.
0
 
LVL 1

Author Comment

by:lefty431
ID: 39234942
I haven't done anything yet, but moved 1 mailbox.  the user is able to send me email, but when I send him email from outside I get a 550 5.7.1 unable to relay.

on the router, I changed the firewall rules to point to the new server.  

I will look at your suggestion and see if I can create that..
0
 
LVL 1

Author Comment

by:lefty431
ID: 39234944
I would need steps.  sorry. I missed that part.  if I move all of the mailboxes over to the new server would I need to do that still?
0
Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

 
LVL 11

Expert Comment

by:James Hodge
ID: 39235026
Hello,

1) create a Routing Group Connector between the 2003 and 2010 Server on the 2010 server(if there is one, delete it and re-create it). This will allow mail to flow between the two servers. You can test this by sending an email from a mailbox on the 2003 server to your test mailbox on the 2010 server.

2) Create a Send connector on the Hub Transport Server on 2010 (will allow outbound email from the 2010 server)

3) Remove the Send Connector on the 2003 Server (will force mailboxes on the 2003 server to route mail via the Hub Transport server (2010)).

4) Change your MX Records / Firewall to route email to the 2010 mail server (NAT port TCP 25 to your 2010 server) - allow DNS propagation time for this to take place.

5) Ensure there is a valid Receive Connector on the 2010 Server (and make sure Anonymous Users have access under the Permission Groups tab of the receive conenctor - common problem)

This will get you into a position where mail can flow in and out of the company. Then you can complete the migration :)

James Hodge
0
 
LVL 1

Author Comment

by:lefty431
ID: 39235050
ok.  I will go through your list. some stuff might be done, but I will delete and redo..
0
 
LVL 1

Author Comment

by:lefty431
ID: 39235124
On the send connector..

do I pic
Use domain names system dns
or
Rout mail through the following smart host?

I assume the firs tone since the 2003 server will be going away
0
 
LVL 44

Expert Comment

by:Amit
ID: 39235210
Check 2003 SMTP configuration, if you are using ISP or DNS,
0
 
LVL 1

Author Comment

by:lefty431
ID: 39235387
on which server?
0
 
LVL 1

Author Comment

by:lefty431
ID: 39235393
i did the steps as described.  same problem.  users can send email if they are on the new server and they can't receive email from outside.  on either server.

I get no error messages NDR's either..
0
 
LVL 11

Expert Comment

by:James Hodge
ID: 39235452
Does the routing group connector now work?  That's a starting point.

Unless there is a smart host configured on the 2003 connector and as long as DNS is configured correctly on the 2010, choose DNS to route email.
0
 
LVL 11

Expert Comment

by:James Hodge
ID: 39235473
Regards receiving external email:

1) ensure your MX Record points at your static IP address. You can check this on mxtoolbox
2) chck your firewall forwards port 25 (smtp) to internal ip of 2010 server
3) ensure there is a valid receive connector on 2010 (with anonymous ticked)

James
0
 
LVL 1

Author Comment

by:lefty431
ID: 39235647
1.  mx records point to the public IP.
  I changed the service group ans swapped IP addresses from the old exchange server to the new..  

2.  firewall is good.  with the rule change I made on 1.   no software firewall is on.
3.  I though I did this.  there are 2 listed.  one intranet and one internet..  assuming this is correct...
0
 
LVL 11

Expert Comment

by:James Hodge
ID: 39235676
Yep. Key point is that the Anonymous group has permissions on this.

Do the settings under Organisation Configuration --> Hub Transport --> Accepted Domains look correct? Your @<domainname>.<com> should be here.
0
 
LVL 11

Expert Comment

by:James Hodge
ID: 39235683
Server 2008 R2? Make sure TCP port 25 is open on the Windows Firewall.
0
 
LVL 44

Expert Comment

by:Amit
ID: 39235775
login to exrca.com site and test the mail flow from there. You will find the root cause.
0
 
LVL 1

Author Comment

by:lefty431
ID: 39236136
mail flow is successful from excra.

but users are not getting mail in their inbox.  they can send though..

I can connect to smtp server externally...
0
 
LVL 11

Accepted Solution

by:
James Hodge earned 2000 total points
ID: 39238015
But do the mailboxes on the 2010 server successfully receive external email now?
0

Featured Post

Survive A High-Traffic Event with Percona

Your application or website rely on your database to deliver information about products and services to your customers. You can’t afford to have your database lose performance, lose availability or become unresponsive – even for just a few minutes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question