Solved

Quickbooks Pro 13 Accounts Copy

Posted on 2013-06-10
39
778 Views
Last Modified: 2013-11-21
Hi Guys,

I have a weird issue in quickbooks. When users try to create a accounts copy, and save, it fails with a generic error of failed

Now, bit of background, quick books sits on a terminal server, as does the data. Users cannot see the servers drives, rather it maps drives to folders on them that they have access to

I tested the issue with an admin account, no problem

I test it with one of the users, problem.

I copied the company file into their my documents and ran it, again no problem

I compared the permissions on the folders for both the documents and network folder and they are both the same?

I cannot see a reason why it doesnt work other than the fact it is ran through a mapped drive?

 

Any ideas?
0
Comment
Question by:FSIFM
  • 19
  • 9
  • 9
39 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39235347
More information is required on what drives you are mapping and how; what is the path of the applicaiton; what is the path for the data; the structure of the application; error message and code thrown (perhaps look at the event viewer).
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39236931
Hi Mutawadi,

Quickbooks is installed on the C drive. Users cannot access the drive outside of the application
Data is held on D which is not visible. The mapped drive is F which points to a folder on D which holds the quickbooks data

The drive is mapped by GPO

The users personal folders (my documents, desktop etc) are also on the d drive in another folder, and as stated if the file is opened from there it works fine

The error message occurs

An unexpected error has occured in "QuickBooks Pro":
Sybase Error: ***** SQL error: Cannot access file '\\192.168.21.133\D$\Data\Accounts\Accounts Public\QuickBoo...' -- Permission denied
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39239112
It is clearly a permissioning issue. Well, check what is the permissions given to the service account QBDataServiceUser20. Does it show Full Control on This Folder and Files? You can check that on the security tab of the folder -> Advanced button.

If this is the case, then double click on the entry for QBDataServiceUser20 in the Advanced button and change 'Apply to' to This Folder, Sub Folder and Files.

If this doesn't work then go back to the security properties of the folder -> Advanced Button -> Change Permissions Button -> tick the checkbox Replace all child object permissions with inheritable permissions from this object -> click OK three times.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39240268
Hi Mutawadi,

I'd agree, but unfortunately it doesn't seem to be. As you suggested i ensured the service account had full control under the advanced permissions menu. I even went one farther and added authenticated users and granted them full control. I then did a replace permissions, but the issue is still occurring?
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39240274
And i have just tried even giving the service account ownership rights over the directory. Still no luck :(
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39240289
On which directory have you set the permissions?
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39240293
I set the permissions on the root directory for their qb data and i set the ownership in a sub test folder that i had a copy of one of the files in
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39240301
Is this \\192.168.21.133\D$\Data\Accounts\Accounts Public\QuickBoo..?

How is the above different for each user?
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39240327
Yea its the Quickbooks Data folder

All of the users data sits on the D drive, which they cannot see directly
(they can access it via UNC though)

From a users perspective their personal folders are mapped to a folder on the d (ie. D:\Userdata\%Username%\)

They access shared data via mapped drives which also sit on D

ie for Quick books F:\Accounts Public\QuickBook Data\
(real path D:\Data\Accounts\Accounts Public\QuickBook Data\)
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39240465
Ok so you granted full control for the service account on D:\Data and propagated the permissions to all the sub folders.  You did the same for Authenticated users? The latter is an issu because this will allow users see each other individuals data!
Can you also grant permission to the service account on the main directory where the QB is installed.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39240481
No, the permissions was granted for both at the quickbooks data directory

D:\Data\Accounts\Accounts Public\QuickBook Data\

Not data for that very reason ;)

All quickbooks company files are in that directory and its subfolders

The service account also has full permissions against the directory QB is installed on
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39244011
Let me see if I can find any additional reason for the issue.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39244012
Cheers Mutawadi
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39251705
Try to give full permissions to your users on the following registry keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Intuit
HKEY_CLASSES_ROOT\QuickBooks.CoLocator
HKEY_CLASSES_ROOT\QuickBooks.CoLocator.1
C:\Program Files\Intuit
C:\Program Files\Common Files\Intuit

If this doesn't work then give the full permissions to the service account on the above registry keys.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39256620
Hi Mutawadi,

I've tried the above with full permissions to both the users and the service account but still no luck :(
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39259303
If you are using 64-bit (2008 R2) servers then try doing so on the Wow6432Node version of the registry keys.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39259735
Hi Mutawaidi

Already 2 steps ahead, quick books doesn't have those keys outside of the wow6432node so i had performed the changes to the keys in that location

Still no luck :(
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39269017
I am sorry, there is not much I can help with as I am not face to face with the system.
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39296559
I think your problem is in the path "Cannot access file '\\192.168.21.133\D$\Data\Accounts\Accounts ". The D$ is only useable by administrators and I don't quite understand how it got there.
On the server, as the administrator, map the folder to F, run the QB Database Manager and change the watched folder to F.  I'll bet that fixes it.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39306519
That does sound quite likely, however when i try to add the folder in QB Manager, it complains the mapped drive is not local drive
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39332827
Also i appear to be able to access as one of the users \\192.168.21.133\d$\
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39333033
What happens when you tell the QB Database Manager to watch the real folder? (i.e. C:\Data\Quickbooks)
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39333133
Hi Davis,

It already is presently
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39333170
And if you map the F drive for the user(s) as D:\yadayada?
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39333206
I could give it a shot, though I'm not sure on what the behavior would be since the D drive does exist in the background, it just isn't visible to the users?
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39333450
Since it is all local, I don't understand why it got set as \\192.168.21.133\d$\ in the first place
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39335854
Pretty much D is hidden as it contains both users data directories (my documents, desktop etc) and shared data

These shared data folders are then mapped for the users so rather than have access to the root of D they just see the shared folders

They also have a number of spreadsheet etc they previously had mappings to those mapped drives on their old network so it was simpler to do it this way to make it as painless as possible when migrating them
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39337899
I still don't understand why it isn't mapped as D:\Data\Accounts\Accounts Public\QuickBoo...
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39344236
Hi Davis,

Technically it is, thats the path, but the client wants it presented as F:\Accounts Public
The brought so much storage off us, so its all pooled on one drive, so thats its shared between each folder

Also they're run into another problem now. It appears that when they cut a qb company file and paste it to their desktops to create a accounts copy, then cut and paste both back to the share, when they or another other user tries to access the qb company file they get an access denied message.

If i as an administrator log into the file then log off it then works fine for them all?

Yet they have full admin rights against the directory?
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39344405
No; technically its \\192.168.21.133\d$\... which is what's causing the  problem.  It puts the folder in the internet zone with much more restrictive permissions and only the administrator has full access to the d$.
Logged in as a user, right-click and disconnect from the F drive.  Then in a CMD prompt, type NET USE F: "D:\Data\Accounts\Accounts Public\" and see if it works.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39344446
That produces the error "the network name cannot be found"

But if it is the internet zone that is causing the problem, could the solution be to add the local host to the trusted zone?
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39344606
Did you create a new share of the D drive or just use the default d$ which was already there?
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39344620
Just the default of D$
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39344866
Would it be worth sharing the directories and mapping to the shared folders instead?
0
 
LVL 42

Accepted Solution

by:
Davis McCarn earned 500 total points
ID: 39345765
Normally, you are supposed to create a new share if is the root of the drive so that two appear in the shares section of Computer Management.  Because you don't want the root available to the users; yes, make new shares that are the folders.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 39348547
Davis, you are a genius. All fixed :) cheers mate
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39348710
You're welcome!
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now