Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1332
  • Last Modified:

MS SQL Management Studio Overtype mode

I have an issue with a windows 7 pro computer and I'm only having this problem within SQL management studio. When I double click within the code pane--for example if I try to highlight a line of code, or if I simply double click within empty space--the text cursor changes to overtype mode. It's very frustrating because I then have to click the insert button every time I double click. If I try this in any other application--word, notepad, etc, I don't have this problem.

Thanks in advance
0
BitTrekker
Asked:
BitTrekker
1 Solution
 
PortletPaulCommented:
abnormal insert in an editor = not nice, and I'm not certain any of this will help I'm afraid:
msdn ssms documentation seems to discuss 2005 or 2012 so I apologize in advance if its not the right version:

SQL Server Management Studio offers users two keyboard schemes. By default, it uses the Standard scheme, with keyboard shortcuts based on Microsoft Visual Studio. A second scheme, called SQL Server 2000, closely resembles the tools from SQL Server 2000, in particular the keyboard shortcuts from the Query Analyzer. In a few cases, SQL Server Management Studio cannot offer the keyboard shortcuts from Query Analyzer. To change the keyboard scheme or add additional keyboard shortcuts, on the Tools menu, click Options. Select the desired keyboard scheme on the Environment, Keyboard page.
http://msdn.microsoft.com/en-us/library/ms174205(v=sql.100).aspx

Not sure if IntelliSense is relevant either - might be
http://msdn.microsoft.com/en-US/library/ms173743(v=sql.110).aspx (2012)
http://msdn.microsoft.com/en-US/library/ms173743(v=sql.90).aspx (2005: shouldn't be relevant really - but what the heck)

getting even more generic now:
Query and Text Editors (SQL Server Management Studio) - 2012
http://msdn.microsoft.com/en-us/library/ms173477.aspx

Editing Scripts and Files in SQL Server Management Studio - 2005
http://msdn.microsoft.com/en-us/library/ms173457(v=sql.90).aspx

wish I had the simple fix for you - but don't.
0
 
sameer2010Commented:
Hi,

Can you go to Tools -> Options -> Keyboard and select Default scheme and click reset?

Thanks,
Sam
0
 
nemws1Database AdministratorCommented:
Are you running any clipboard or other keyboard handling utilities?  I had something similar happen to me (Ctrl-C to copy didn't work in SSMS) and it turned out to be a bad line in my AutoHotKey configuration file (3rd party app that does keyboard shortcuts).  Maybe something similar in your case??
0
 
BitTrekkerAuthor Commented:
Thanks, it was a third party addon. User wasn't sure how it got there.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now