Solved

Trunk port

Posted on 2013-06-10
3
826 Views
Last Modified: 2013-06-14
Hi guys i have trouble create trunk ports between cisco switch 3550 and HP2510 switch with HP to understand vlans and assign port into them. I know how to configure cisco trunk ,but not so sure about HP config.Thanks.
0
Comment
Question by:homolama
3 Comments
 
LVL 42

Assisted Solution

by:paulsolov
paulsolov earned 167 total points
ID: 39237071
In hp terms the vlan is either tagged or untagged. HP uses a different terminology for a trunk port (Link Aggregation) than does cisco.

Essentially you create VLANs and either make them tagged or untagged for 802.1q.  You can also create an HP trunk port (link aggregation port such as LACP or static link aggregation with multiple ports and assign which VLANs are tagged and untagged on it on the HP side

this link will show you how to configure lacp link aggregation on hp side (etherchannel equivalent on the cisco side just use lacp on cisco as well).  This will allow for redundancy

http://onlyblueatwork.wordpress.com/2012/02/06/enable-802-3ad-lacp-on-hp-procurve-switches/


Next you want to configure tagging on both sides (803.1q trunk)

For vlan tagging you can use the following HP guide, look at page 2-27

ftp://ftp.hp.com/pub/networking/software/2510-AdvTrafficMgmt-Aug2006-59914762.pdf

You can use the menu command in the CLI to get to the menu and get it done that way.  I would also recommend to use STP if not already configured to ensure that system is blocking correctly.
0
 
LVL 17

Assisted Solution

by:TimotiSt
TimotiSt earned 166 total points
ID: 39237203
First things first: 'trunk port' means a completely different thing on HP and Cisco.
Cisco calls ports with tagged vlans a trunk port, and aggregated links etherchannel.
HP calls ports with tagged vlans a tagged port, and aggregated links trunks.

So, on the HP side, you'll need to assign vlans as tagged (and possibly untagged) to a port to make it play with a Cisco trunk port. Also, you don't assign vlans under the interface, you assign interfaces under the vlan. But it's really simple:
vlan 1 
   name "DEFAULT_VLAN" 
   no ip address 
   no untagged 1-49,50
   exit 
vlan 31 
   name "vlan31" 
   tagged 50
   exit 
vlan 30 
   name "vlan30" 
   untagged 1,11-12,30,38,44,49 
   ip address 192.168.30.231 255.255.255.0 
   tagged 50
   exit 
vlan 23 
   name "VLAN23" 
   untagged 2-10,13-29,31-37,39-43,45-48 
   tagged 50
   exit 
vlan 29 
   name "VLAN29" 
   tagged 50
   exit 

Open in new window

Port 50 is a tagged port here.
0
 
LVL 45

Accepted Solution

by:
Craig Beck earned 167 total points
ID: 39237219
Just to add to what paulsolov said, the way I think about it (if it helps you understand) is:

For Cisco, you assign VLANs to ports.  For HP, you assign ports to VLANs.
Native VLAN (in Cisco talk) = Untagged (in HP talk)

As an example, to get a port between a Cisco switch and HP switch to talk VLANs:

Cisco Switch

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk native vlan 10
 switchport trunk allowed vlan 10,20,30


HP Switch (using port 1)

vlan 10
 untagged 1
       '1' is the port number
vlan 20
 tagged 1
vlan 30
 tagged 1
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Losing network connectivity 8 77
VoIP and Data on single switch, with SonicWall 6 54
OSPF Cost 2 51
The purpose of using BGP 33 75
So, you're experiencing issues on your network and you've decided that you need to perform some tests to determine whether your cabling is good.  You're likely thinking that you may need to spend money which you probably don't have on hiring/purchas…
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now